DOMbasic: Lista de 'namespaces'

DOMbasic 1.0
DOMBasic es un Framework PHP para la creación de elementos DOM que generan contenido HTML dinámico y permite su modificación 'al vuelo' (Websites). Está escrito entéramente en PHP y sigue el paradigma POO.
  • Página principal
  • Namespaces
  • Estructuras de Datos
  • Lista de 'namespaces'
Lista de 'namespaces'
Lista de toda la documentación de los 'namespaces', con una breve descripción:
N DOMBase
N DOMBasic
Generado por doxygen 1.8.10


DOMbasic: Referencia del Namespace DOMBase

DOMBasic es un Framework PHP para la creación de elementos DOM que generan contenido HTML dinámico y permite su modificación 'al vuelo' (Websites). Está escrito entéramente en PHP y sigue el paradigma POO.
  • Página principal
  • Namespaces
  • Estructuras de Datos
  • Lista de 'namespaces'
Referencia del Namespace DOMBase

Descripción detallada

DOMBaseException is a container from which all other exceptions in the components library descent.

Versión
1.0


DOMbasic: Referencia del Namespace DOMBasic

DOMBasic es un Framework PHP para la creación de elementos DOM que generan contenido HTML dinámico y permite su modificación 'al vuelo' (Websites). Está escrito entéramente en PHP y sigue el paradigma POO.
  • Página principal
  • Namespaces
  • Estructuras de Datos
  • Lista de 'namespaces'
Referencia del Namespace DOMBasic

Descripción detallada

DOMBasicAttribNotFoundException is thrown whenever a non existent property is accessed in the Components library.

Versión
1.0

DOMBasicAttribReadOnlyException is thrown whenever a read-only attrib is tried to be changed, or when a write-only attrib was accessed for reading.

Versión
1.0

DOMBasicAutoloadException is thrown whenever a class can not be found with the autoload mechanism.

Versión
1.0

DOMBasicElementNotFoundException is thrown whenever a non existent element is accessed in the elements array.

Versión
1.0

DOMBasicElementReadOnlyException is thrown whenever a read-only element DOM is tried to be changed.

Versión
1.0

DOMBasicSingletonException is thrown whenever a static instance element is tried to get, field $PATRON_SINGLETON dependency in CONFIGURATION.

Versión
1.0

DOMBasicValueException is thrown whenever the type or value of the given variable is not as expected.

Versión
1.0


DOMbasic: Estructura de datos

DOMBasic es un Framework PHP para la creación de elementos DOM que generan contenido HTML dinámico y permite su modificación 'al vuelo' (Websites). Está escrito entéramente en PHP y sigue el paradigma POO.
  • Página principal
  • Namespaces
  • Estructuras de Datos
  • Estructura de datos
  • Índice de estructura de datos
  • Jerarquía de la clase
  • Campos de datos
Estructura de datos
Lista de estructuras con una breve descripción:
C Configuration
C DOM_attribs
C DOM_element
C DOM_Interface
C DOM_textNode
C DOMBasicAttribNotFoundException
C DOMBasicAttribReadOnlyException
C DOMBasicAutoloadException
C DOMBasicElementNotFoundException
C DOMBasicElementReadOnlyException
C DOMBasicException
C DOMBasicSingletonException
C DOMBasicValueException
C INI


DOMbasic: Referencia de la Clase Configuration

DOMBasic es un Framework PHP para la creación de elementos DOM que generan contenido HTML dinámico y permite su modificación 'al vuelo' (Websites). Está escrito entéramente en PHP y sigue el paradigma POO.
  • Página principal
  • Namespaces
  • Estructuras de Datos
  • Estructura de datos
  • Índice de estructura de datos
  • Jerarquía de la clase
  • Campos de datos
Métodos públicos | Métodos públicos estáticos | Campos de datos
Referencia de la Clase Configuration

Métodos públicos

__get ($section)
getAvailableSections ()

Métodos públicos estáticos

static | objectToArray ($obj)
static & | getInstance ($file, $type=Configuration::AUTO)

Campos de datos

const | AUTO = 0
const | JSON = 2
const | PHP_INI = 4
const | XML = 16

Descripción detallada

DOWNLOADED OF PHP.NET (AUTHOR: Mauro Gabriel Titimoli)

multiple configuration type class.

$configuration = Configuration::getInstance($configuration_File_Name); foreach($configuration->getAvailableSections() as $pos => $sectionName) { var_dump($sectionName); var_dump($configuration->{$sectionName}); }

Documentación de las funciones miembro

static objectToArray ( $obj )
static

PRECAUCION: METODO RECURSIVO.

La documentación para esta clase fue generada a partir del siguiente fichero:
  • objetosPHP/util/JsonIniXml.php


DOMbasic: Referencia de la Clase DOM_attribs

DOMBasic es un Framework PHP para la creación de elementos DOM que generan contenido HTML dinámico y permite su modificación 'al vuelo' (Websites). Está escrito entéramente en PHP y sigue el paradigma POO.
  • Página principal
  • Namespaces
  • Estructuras de Datos
  • Estructura de datos
  • Índice de estructura de datos
  • Jerarquía de la clase
  • Campos de datos
Métodos públicos | Métodos públicos estáticos | Campos de datos | Métodos protegidos | Atributos protegidos
Referencia de la Clase DOM_attribs
Diagrama de herencias de DOM_attribs
DOM_element DOM_textNode

Métodos públicos

__construct ($asocArrayAttribs=null)
setReadOnly ($readOnly)
getReadOnly ()
reinicializar ()
__get ($attrib)
__set ($attrib, $value)
__isset ($attrib)
__unset ($attrib)
offsetExists ($attrib)
offsetGet ($attrib)
offsetSet ($attrib, $value)
offsetUnset ($attrib)
getIterator ()
setAttribs ($asocArrayAttribs)
getAttribs ()
getAttribsStr ()
addAttrib ($attrib, $valorAttrib)
addAttribs ($arrayAttribs)
removeAttrib ($attrib)
removeAttribs ($arrayAttribs)
clearAttribs ()
countAttrs ()
equals ($objAttribs)
__toString ()
toJSON ($return=true, $base64values=true)
fromJSON ($arrJSON)
setEjemplo ()

Métodos públicos estáticos

static | arrayFromURL ($strURLquery)
static | filtrarStrJSON ($str="")
static | writeLog ($mensaje, $trace)

Campos de datos

const | N_C = __CLASS__
const | ENCODE_RFC_1738 ="RFC_1738"
const | ENCODE_RFC_3986 ="RFC_3986"

Métodos protegidos

tryingWrite ($arg="")
toURL ($encode=self::ENCODE_RFC_3986)
fromURL ($strURLquery)

Atributos protegidos

$_READ_ONLY =false
$AVISO_GET =false
$_attribs =array()

Descripción detallada

Interfaz para crear atributos de elementos DOM. Para que objetos derivados del DOM (como links, ...) implementen atributos HTML.

El programador debe asegurarse que son nombres estandarizados para los atributos de elementos DOM. (W3C)

TODO: FILTRADO: <del>Solo se admitiran nombres estandarizados para los atributos de elementos DOM. (W3C)</del>

Admite CONCATENACION DE METODOS mediante el retorno de la construccion '$this' en todos los metodos 'NO-GETTER': … $this->setAttrib('href','http://www.uno.com/')->removeAttrib('href'); …

Documentación del constructor y destructor

__construct ( $asocArrayAttribs = null )

CONSTRUCTOR PHP 5, CON ENTREGA DIRECTA DE ATRIBUTOS.

El parametro sera un array asociativo de atributos con pares correctos 'clave=valor'.

El programador debe asegurarse que son nombres estandarizados para los atributos de elementos DOM.(W3C)

TODO: FILTRADO: <del>Solo se admitiran nombres estandarizados para los atributos de elementos DOM. (W3C)</del>

Parámetros
$asocArrayAttribs Array de pares 'clave=valor' de atributos DOM.

Documentación de las funciones miembro

__get ( $attrib )

Property get access. Simply returns a given attrib.

Excepciones
DOMAttribNotFoundException If a the value for the property attrib is not an instance of
Parámetros
string $attrib The name of the attrib to get.
Devuelve
mixed The attrib value.
Excepciones
DOMBasicAttribNotFoundException | if the given property does not exist.
DOMBasicAttribReadOnlyException | if the attrib to be set is a write-only property.
__isset ( $attrib )

Returns if an attrib exists. (Desde PHP 5.1.0 )

Parámetros
string $attrib Attrib name to check for.
Devuelve
bool Whether the attrib exists.
__set | ( | $attrib,
 |  | $value
 | ) |

Sets an attrib. This method is called when an attrib is set.

Parámetros
string | $attribName | The name of the attrib to set.
mixed | $attribValue | The attrib value.
Devuelve
DOM_element $this este elemento (DOM). (NO-UTIL)
Excepciones
DOMBasicAttribNotFoundException | if the given attrib does not exist.
DOMBasicValueException | if the value to be assigned to a attrib is invalid.
DOMBasicAttribReadOnlyException | if the attrib to be set is a read-only attrib.
__unset ( $attrib )

Desde PHP 5.1.0

Excepciones
DOMBasicAttribReadOnlyException | If 'Read Only' ON.
DOMBasicAttribNotFoundException | If $attrib is not a key in the $_attribs array.
Parámetros
string $attrib The name of the attrib to unset.
addAttrib | ( | $attrib,
 |  | $valorAttrib
 | ) |

El programador debe asegurarse que los atributos aportados son nombres estandarizados y valores validos para los atributos de elementos DOM.(W3C)

Retorna <del>el total de los atributos establecidos si no hay exceptcion.</del> $this

TODO: FILTRADO: <del>Solo se admitiran nombres estandarizados para los atributos de elementos DOM. (W3C)</del>

Excepciones
DOMBasicAttribNotFoundException | If $attrib is not a key in the $_attribs array.
DOMBasicValueException | If the value for a attrib is out of range.
Parámetros
string | $attrib | The name of the attrib to add.
mixed | $valorAttrib | The value of the attrib to add.
Devuelve
DOM_element $this este elemento (DOM).
addAttribs ( $arrayAttribs )

Añade atributos (si no existian previamente). El parametro sera un array asociativo de atributos con pares correctos 'clave=valor'.

Retorna <del>el total de los atributos establecidos.</del> $this

El programador debe asegurarse que son nombres estandarizados (y valores validos) para los atributos de elementos DOM.(W3C)

TODO: FILTRADO: <del>Solo se admitiran nombres estandarizados para los atributos de elementos DOM. (W3C)</del>

Excepciones
DOMBasicAttribNotFoundException | If $attrib is not a key in the $_attribs array.
DOMBasicValueException | If the value for a attrib is out of range.
Parámetros
array $arrayAttribs The array of the attribs to add.
Devuelve
DOM_element $this este elemento (DOM).
static arrayFromURL ( $strURLquery )
static

Retorna un array de atributos con sus correspondientes valores extraidos de una cadena con el formato de las URL's.

El parametro es la cadena desde la que se extraeran los atributos y sus valores, esta cadena tendra el formato de las URL's (relativa o absoluta) donde debe incluirsele una 'queryString' (entre '?' y '#'), Igual a la generada por el metodo toURL().

Parámetros
$strURLquery Cadena desde la que se extraeran los atributos y sus valores, esta cadena tendra el formato entregado en las URL's como parte de su 'queryString' (entre '?' y '#').
Devuelve
Array de atributos extraidos de la queryString.
clearAttribs ( )

Suprime o elimina todos los atributos. Retorna <del>el numero de atributos que quedan.</del> $this

Excepciones
DOMBasicAttribNotFoundException | If $attrib is not a key in the $_attribs array.
DOMBasicValueException | If the value for a attrib is out of range.
Devuelve
DOM_element $this este elemento (DOM).
countAttrs ( )

Retorna el total de los atribuos establecidos.

Devuelve
int Total de atributos establecidos
equals ( $objAttribs )

Compara si otro objeto es igual a este (no si es el mismo); para esto se tienen que cumplir las siguientes normas:

  • Que los dos sean instancias de la misma Clase (DOM_attribs).
  • Que los dos tengan definidos el mismo numero de atributos y con los mismos valores.
Parámetros
DOM_attribs $objAttribs Algun objeto instancia de esta Clase
Devuelve
boolean
static filtrarStrJSON ( $str = "" )
static

Limpia una cadena de RETORNOS DE CARRO, AVANCES DE LINEA y TABULACIONES, preparandola asi para datos JSON

fromURL ( $strURLquery )
protected

Establece y retorna un array de atributos con sus correspondientes valores extraidos de una cadena con el formato de las URL's, para construir Atributos de este Objeto.

El parametro es la cadena desde la que se extraeran los atributos y sus valores, esta cadena tendra el formato de las URL's (relativa o absoluta) donde debe incluirsele una 'queryString' (entre '?' y '#'), Igual a la generada por el metodo toURL().

Parámetros
$strURLquery Cadena desde la que se extraeran los atributos y sus valores, esta cadena tendra el formato entregado en las URL's como parte de su 'queryString' (entre '?' y '#').
Devuelve
Array de atributos extraidos de la queryString.
getAttribs ( )

Retorna todos los atributos establecidos como un array asociativo 'clave=valor'.

Devuelve
array assoc attribs (key=value) or null if not defined.
getAttribsStr ( )

Retorna todos los atributos establecidos como una cadena con los pares 'clave=valor' separados por espacios.

Si el atributo comienza con la palabra reservada '_null' entonces solo imprimira el valor entrecomillado, por el contrario si el valor es 'nulo' entonces solo imprimira la clave (sin comillas).

Este metodo esta pensado para poder retornar atributos de etiquetas XHTML (y XML), donde existen casos de atributos sin valor y otros de atributos sin clave (por ej. en la etiqueta 'DOCTYPE')

Es sinonimo de '__toString()'.

OJO !!: Que sea sinonimo no significa que pueda llamarse dentro de esta funcion a '__toString()' ya que crearia una REFERENCIA CIRCULAR!..

;

Devuelve
string Cadena de pares 'attrib="attribValue"' separados por espacios
getReadOnly ( )
abstract

Comprueba si los atributos de este elemento son DE SOLO LECTURA O ESCRIBIBLES.

Devuelve
boolean
offsetExists ( $attrib )

Returns if an attrib exists. Allows isset() using ArrayAccess.

Parámetros
string $attrib The name of the attrib to get.
Devuelve
bool Whether the attrib exists.
offsetGet ( $attrib )

Returns an attrib value. Get an attrib value by ArrayAccess.

Excepciones
DOMBasicAttribNotFoundException If $attrib is not a key in the $_attribs array.
Parámetros
string $attrib The name of the attrib to get.
Devuelve
mixed The attrib value.
offsetSet | ( | $attrib,
 |  | $value
 | ) |

Set an attrib. Sets an attrib using ArrayAccess.

Excepciones
DOMBasicAttribNotFoundException | If $attrib is not a key in the $_attribs array.
DOMBasicValueException | If the value for a attrib is out of range.
Parámetros
string | $attrib | The name of the attrib to set.
mixed | $attrib | The value for the attrib.
Devuelve
DOM_element $this este elemento (DOM).
offsetUnset ( $attrib )

Unset an attrib. Unsets an attrib using ArrayAccess.

Excepciones
DOMBasicAttribNotFoundException | If $attrib is not a key in the $_attribs array.
DOMBasicValueException | If the value for a attrib is out of range.
Parámetros
string $attrib The name of the option to unset.
reinicializar ( )
abstract

Pone a cero los elementos de arrays de este Objeto.

Devuelve
DOM_element $this este elemento (DOM).
removeAttrib ( $attrib )

Suprime o elimina el atributo indicado (si es que existe). Retorna <del>el numero de atributos que quedan.</del> $this

Excepciones
DOMBasicAttribNotFoundException | If $attrib is not a key in the $_attribs array.
DOMBasicValueException | If the value for a attrib is out of range.
Parámetros
string $attrib The name of the attrib to remove.
Devuelve
DOM_element $this este elemento (DOM).
removeAttribs ( $arrayAttribs )

Suprime o elimina todos los atributos indicados (si es que existen). Retorna <del>el numero de atributos que quedan.</del> $this

Excepciones
DOMBasicAttribNotFoundException | If $attrib is not a key in the $_attribs array.
DOMBasicValueException | If the value for a attrib is out of range.
Parámetros
array string $arrayAttribs Array with the attribs's name to remove.
Devuelve
DOM_element $this este elemento (DOM).
setAttribs ( $asocArrayAttribs )

El parametro sera un array asociativo de atributos con pares correctos 'clave=valor'.

El programador debe asegurarse que son nombres estandarizados para los atributos de elementos DOM.(W3C)

TODO: FILTRADO: <del>Solo se admitiran nombres estandarizados para los atributos de elementos DOM.(W3C)</del>

Excepciones
DOMBasicAttribNotFoundException | If $attrib is not a key in the $_attribs array.
DOMBasicValueException | If the value for a attrib is out of range.
Parámetros
array $asocArrayAttribs The array of the attribs to set.
Devuelve
DOM_element $this este elemento (DOM).
setReadOnly ( $readOnly )
abstract

Establece si los atributos de este elemento son DE SOLO LECTURA O ESCRIBIBLES.

Parámetros
boolean
Devuelve
DOM_element $this este elemento (DOM).
toJSON | ( | $return = true,
 |  | $base64values = true
 | ) |

Metodo para retornar la cadena JSON que representa estos atributos en la forma '{"clave1":"valor1", "clave2":"valor2"}'.

Aporta un segundo parametro para codificar todos los valores (no las claves) en 'base64', (DEFECTO=true), asi podriamos evitar el problema de los tipos de codificacion empleados (JSON solo admite UTF-8).

NO UTILIZA LA FUNCION PHP 'json_encode(..)'

<del>Utiliza las siguientes constantes PHP 5.3: JSON_HEX_QUOT && JSON_HEX_TAG && JSON_HEX_AMP && JSON_HEX_APOS</del>

Parámetros
boolean | $return | Indica si retornar el resultado (TRUE) o imprimirlo (FALSE).
boolean | $base64values | Indica si codificar los textos en 'base64' o no.
Devuelve
String JSON de estos atributos o NULL en caso de desear imprimirlo.
toURL ( $encode = self::ENCODE_RFC_3986 )
protected

Retorna una cadena con el formato de las URL's, construida con los Atributos de este Objeto.
Contiene un parametro $encode indicando el tipo de codificacion a aplicar: 'RFC_1738' (espacios=+) o 'RFC_3986' (espacions=%20), las cuales estan implementadas como cadenas staticas de esta clase.

Parámetros
$encode Cadena indicando el tipo de codificacion (alguna de las dos constantes de esta clase RFC_1738 o RFC_3986).
Devuelve
Cadena con formato de codificacion URL.
tryingWrite ( $arg = "" )
protected

Notifica una accion de escritura al objeto. Si es de solo-lectura lanzara una Excepcion.

Devuelve
boolean TRUE=OK, FALSE=throw DOMBasicAttribReadOnlyException()
Excepciones
DOMBasicAttribReadOnlyException;

Documentación de los campos

$AVISO_GET =false
protected

¿ Lanzar Aviso cuando se lee un atributo que no existe ?

La documentación para esta clase fue generada a partir del siguiente fichero:
  • objetosPHP/DOM_attribs.php


DOMbasic: Referencia de la Clase DOM_element

DOMBasic es un Framework PHP para la creación de elementos DOM que generan contenido HTML dinámico y permite su modificación 'al vuelo' (Websites). Está escrito entéramente en PHP y sigue el paradigma POO.
  • Página principal
  • Namespaces
  • Estructuras de Datos
  • Estructura de datos
  • Índice de estructura de datos
  • Jerarquía de la clase
  • Campos de datos
Métodos públicos | Métodos públicos estáticos | Campos de datos | Métodos protegidos | Atributos protegidos | Atributos protegidos estáticos
Referencia de la Clase DOM_element
Diagrama de herencias de DOM_element
DOM_attribs DOM_Interface DOM_textNode

Métodos públicos

__construct ($key=null)
__clone ()
__unset ($child)
__toString ()
reinicializar ()
setReadOnly ($readOnly)
getReadOnly ()
setKey (string $key=null)
getKey ()
getTag ()
setTag ($tag)
getOpenTag ()
getCloseTag ()
getType ()
getDesc ()
clearText ()
setText ($text)
addText ($text)
getTextAll ($filter=false)
getText ($filter=false)
addChild (DOM_element $child=null)
addChildren (array $children=null)
setChildren (array $children=null)
getChildren ()
getChildrenAll ()
getChildByKey ($key, $grandchildren=true)
getChildrenByTag ($tag, $grandchildren=true)
getChildrenByType ($type, $grandchildren=true)
removeChild ($child, $grandchildren=true)
removeChildrenAll ()
removeChildByKey ($key, $grandchildren=true)
removeChildrenByTag ($tag, $grandchildren=true)
removeChildrenByType ($type, $grandchildren=true)
equals ($objDOM)
equalsType ($objDOM)
toHTML ()
toJSON ($return=true, $base64values=true)
fromJSON ($json)
fromDOM_element (DOM_element $dom)
attribsToURL ($encode=self::ENCODE_RFC_1738)
attribsFromURL ($strURL)
getConfiguration ()
setConfiguration (array $conf)
importConfINI ($confFile=null)
- Métodos públicos heredados desde DOM_attribs
__construct ($asocArrayAttribs=null)
setReadOnly ($readOnly)
getReadOnly ()
reinicializar ()
__get ($attrib)
__set ($attrib, $value)
__isset ($attrib)
__unset ($attrib)
offsetExists ($attrib)
offsetGet ($attrib)
offsetSet ($attrib, $value)
offsetUnset ($attrib)
getIterator ()
setAttribs ($asocArrayAttribs)
getAttribs ()
getAttribsStr ()
addAttrib ($attrib, $valorAttrib)
addAttribs ($arrayAttribs)
removeAttrib ($attrib)
removeAttribs ($arrayAttribs)
clearAttribs ()
countAttrs ()
equals ($objAttribs)
__toString ()
toJSON ($return=true, $base64values=true)
fromJSON ($arrJSON)
setEjemplo ()

Métodos públicos estáticos

static | getInstance ()
static | getDTD (int $dtd)
static | objJSON2DOM_element ($objectJSON, $return=true, $base64values=true)
- Métodos públicos estáticos heredados desde DOM_attribs
static | arrayFromURL ($strURLquery)
static | filtrarStrJSON ($str="")
static | writeLog ($mensaje, $trace)

Campos de datos

const | N_C = __CLASS__
const | PATRON_SINGLETON =true
const | AVISO_SINGLETON =true
- Campos de datos heredados desde DOM_attribs
const | N_C = __CLASS__
const | ENCODE_RFC_1738 ="RFC_1738"
const | ENCODE_RFC_3986 ="RFC_3986"

Métodos protegidos

tryingWrite ($arg="")
- Métodos protegidos heredados desde DOM_attribs
tryingWrite ($arg="")
toURL ($encode=self::ENCODE_RFC_3986)
fromURL ($strURLquery)

Atributos protegidos

$_READ_ONLY =false
$TAG = ""
$TYPE = "container"
$DESC = "DOM's container element"
$OPEN_TAG_LEFT ="<"
$OPEN_TAG_RIGHT =">"
$CLOSE_TAG_LEFT ="</"
$CLOSE_TAG_RIGHT =">"
$AVISO_GET =false
$_key =""
$_text =""
$_children =array()
- Atributos protegidos heredados desde DOM_attribs
$_READ_ONLY =false
$AVISO_GET =false
$_attribs =array()

Atributos protegidos estáticos

static | $DTD_DOCTYPE_HTML =0
static | $DTD_DOCTYPE_XHTML_TRANSITIONAL =10
static | $DTD_DOCTYPE_XHTML_STRICT =10
static | $DTD_XML_1_0 =20
static | $LINE_BREAK ="\n"
static | $instance

Descripción detallada

Clase padre para crear cualquier elemento del DOM. Admite CONCATENACION DE METODOS mediante el retorno de la construccion '$this' en todos los metodos 'NO-GETTER': … $this->setText('text')->removeChild($child)->importConfINI(); …

Documentación de las funciones miembro

__unset ( $child )

Desde PHP 5.1.0

Excepciones
DOMBasicElementReadOnlyException | If 'Read Only' ON.
DOMBasicElementNotFoundException | If $attrib is not a key in the $_attribs array.
Parámetros
DOM_element $child The element to unset.
addChild ( DOM_element $child = null )

Metodo para agregar un hijo al elemento DOM.

Parámetros
$child Elemento DOM.
Devuelve
DOM_element $this este elemento (DOM).
Ver también
DOM_Interface::addChildren()
DOM_Interface::setChildren()

Implementa DOM_Interface.

addChildren ( array $children = null )

Metodo para agregar un array de hijos de elementos DOM, al ya existente.

Parámetros
$child Elemento DOM.
Devuelve
DOM_element $this este elemento (DOM).
Ver también
DOM_Interface::addChild()
DOM_Interface::setChildren()

Implementa DOM_Interface.

attribsFromURL ( $strURL )

Establece y retorna un array de atributos con sus correspondientes valores extraidos de una cadena con el formato de las URL's, para construir Atributos de este Objeto.

El parametro es la cadena desde la que se extraeran los atributos y sus valores, esta cadena tendra el formato entregado en las URL's como parte de su 'queryString' (entre '?' y '#'), Igual a la generada por el metodo toURL().

Parámetros
$encode Cadena indicando el tipo de codificacion (alguna de las dos constantes indicadas RFC_1738 o RFC_3986).
Devuelve
Array de atributos extraidos de la queryString.
attribsToURL ( $encode = self::ENCODE_RFC_1738 )

Retorna una cadena con el formato de las URL's, construida con los Atributos de este Objeto.
Contiene un parametro $encode indicando el tipo de codificacion a aplicar: 'RFC_1738' (espacios=+) o 'RFC_3986' (espacions=%20), las cuales estan implementadas como cadenas staticas de la clase DOM_attribs.

Parámetros
$encode Cadena indicando el tipo de codificacion (alguna de las dos constantes indicadas RFC_1738 o RFC_3986).
Devuelve
Cadena con formato de codificacion URL.
equals ( $objDOM )

Compara si otro objeto es igual (comparable no clonable) a este (no si es el mismo); para esto se tienen que cumplir las siguientes normas:

  • Que los dos sean instancias de la misma Clase (el mismo tipo de elemento y etiqueta).
  • Que los dos tengan definidos el mismo numero de atributos y con los mismos valores.
  • Que los dos tengan definidos el mismo numero de hijos y con los mismos valores.
  • Tambien que los dos tengan definida la misma clave.
  • Incluso que los dos contengan el mismo texto como contenido.
Parámetros
DOM_element $objDOM Algun objeto instancia de esta Clase
Devuelve
boolean
equalsType ( $objDOM )

Compara si otro objeto es del mismo TIPO que este (no si es el mismo)

Parámetros
DOM_element $objDOM Algun objeto instancia de esta Clase
Devuelve
boolean

Implementa DOM_Interface.

fromDOM_element ( DOM_element $dom )

Metodo para reconstruir este objeto a la imagen y semejanza del objeto DOM_element entregado, con hijos, atributos, y caracteristicas propias.

Parámetros
DOM_element $dom Un objeto de esta clase.
Devuelve
DOM_element Este elemento (this) recreado equivalente (pero no el mismo) al objeto entregado.
fromJSON ( $json )

Metodo para reconstruir este objeto a la imagen y semejanza de la cadena JSON entregada que deberia representar otro DOM_element con hijos, atributos, y caracteristicas propias.

Detecta AUTOMATICAMENTE si el objeto se codifico con 'base64'.

UTILIZA LA FUNCION PHP 'json_decode()' con parametros por defecto.

Parámetros
string $json La cadena json que representa un objeto DOM_element. Esta cadena se construye con la funcion contraria toJSON().
Devuelve
DOM_element El elemento actual (this) reconstruido a la forma del objeto de entrada.

Implementa DOM_Interface.

getChildByKey | ( | $key,
 |  | $grandchildren = true
 | ) |

Metodo para buscar y retornar un hijo del elemento que contenga la misma clave que la pasada por parametro, este metodo es recursivo pero retorna el primer elemento que concuerde su clave, el segundo parametro (por defecto TRUE) indica si comprobar recursivamente en nietos...

CAUTION!: USE RECURSIVE FUNCTION!!

Parámetros
string | $key | La clave del elemento a buscar.
boolean | $grandchildren | TRUE=elimina recursivamente, FALSE=solo mira en los hijos directos.
Devuelve
DOM_element Elemento si es que se encuentra, sino null.
Ver también
DOM_Interface::getChildrenByTag()
DOM_Interface::getChildrenByType()
DOM_Interface::getChildren()
DOM_Interface::getChildrenAll()

Implementa DOM_Interface.

getChildren ( )

Metodo para retornar el array de todos los hijos del elemento DOM. Similar a DOM_Interface::getChildrenAll()

Devuelve
Array de elementos (DOM) con sus atributos correspondientes.
Ver también
DOM_Interface::getChildrenAll()
DOM_Interface::getChildByKey()
DOM_Interface::getChildrenByTag()
DOM_Interface::getChildrenByType()

Implementa DOM_Interface.

getChildrenAll ( )

Metodo para retornar un array con todos los hijos de forma recursiva (nietos, bisnietos, ...) del elemento DOM. Similar a DOM_Interface::getChildren()

Devuelve
Array de elementos (DOM) con sus atributos correspondientes.
Ver también
DOM_Interface::getChildren()
DOM_Interface::getChildByKey()
DOM_Interface::getChildrenByTag()
DOM_Interface::getChildrenByType()

Implementa DOM_Interface.

getChildrenByTag | ( | $tag,
 |  | $grandchildren = true
 | ) |

Metodo para buscar y retornar un array de hijos del elemento que contengan la misma etiqueta (TAG) que la pasada por parametro, el segundo parametro (por defecto TRUE) indica si comprobar recursivamente en nietos...

CAUTION!: RECURSIVE FUNCTION!!

Parámetros
string | $tag | La etiqueta (TAG) del elemento a buscar.
boolean | $grandchildren | TRUE=elimina recursivamente, FALSE=solo mira en los hijos directos.
Devuelve
array(DOM_element) si es que se encuentran, sino un array vacio.
Ver también
DOM_Interface::getChildByKey()
DOM_Interface::getChildrenByType()
DOM_Interface::getChildren()
DOM_Interface::getChildrenAll()

Implementa DOM_Interface.

getChildrenByType | ( | $type,
 |  | $grandchildren = true
 | ) |

Metodo para buscar y retornar un array de hijos del elemento que sean del mismo tipo (TYPE) que el pasado por parametro, el segundo parametro (por defecto TRUE) indica si comprobar recursivamente en nietos...

CAUTION!: RECURSIVE FUNCTION!!

Parámetros
string | $type | El tipo (TYPE) del elemento a buscar.
boolean | $grandchildren | TRUE=elimina recursivamente, FALSE=solo mira en los hijos directos.
Devuelve
array(DOM_element) si es que se encuentran, sino un array vacio.
Ver también
DOM_Interface::getChildByKey()
DOM_Interface::getChildrenByTag()
DOM_Interface::getChildren()
DOM_Interface::getChildrenAll()

Implementa DOM_Interface.

getCloseTag ( )

Metodo para leer la etiqueta HTML de cierre construida para este elemento, con sus atributos incluidos.

NOTE: Existen elementos que deben establecer la suya propia, como los elementos autocontendios (<img />, </br >, ...) o elementos sin etiqueta como 'textNode'.

Devuelve
String con la etiqueta HTML de cierre.

Implementa DOM_Interface.

getConfiguration ( )

Leer la configuracion de este elemento

Devuelve
array
Ver también
DOM_Interface::setConfiguration()
DOM_Interface::importConfINI()

Implementa DOM_Interface.

getDesc ( )

Metodo para leer la descripcion DOM de este elemento.

Devuelve
String con la descripcion de este elemento DOM.

Implementa DOM_Interface.

static getDTD ( int $dtd )
static

Metodo para obtener una etiqueta de definicion DTD que especifique el tipo de documento que estamos tratando. (HTML, XHTML, XML, ...)

Parámetros
int $dtd Un entero identificando el tipo de DTD a retornar. Puede ser una de las constantes de esta clase que comienzan con DTD_
Devuelve
string La cadena con el DTD solicitado.
static getInstance ( )
static

PATRON SINGLETON. Tomar una instancia de forma estatica.
$attrbs = DOM_attribs::getInstance();

getKey ( )

Metodo para tomar la clave del elemento.

Devuelve
String con la clave de este elemento.

Implementa DOM_Interface.

getOpenTag ( )

Metodo para leer la etiqueta HTML de apertura construida para este elemento, con sus atributos incluidos.

Devuelve
String con la etiqueta HTML de apertura.

Implementa DOM_Interface.

getTag ( )

Metodo para leer la etiqueta DOM de este elemento.

Devuelve
String con la etiqueta de este elemento DOM.

Implementa DOM_Interface.

getText ( $filter = false )

Metodo para retornar el texto de este elemento DOM (la concatenacion de los textos de todos los elementos textNode).

Parámetros
$filter [boolean] Permite especificar si el texto se retorna filtrado mediante 'htmlspecialchars_decode(...)' y 'stripcslashes(...)' o no. [Por defecto NO]
Devuelve
string con el texto de todos los nodos tipo 'textNode' de este elemento.
getTextAll ( $filter = false )

Retorna todo el texto encontrado en este elemento y en sus hijos.

Parámetros
$filter [boolean] Permite especificar si el texto se retorna filtrado mediante 'htmlspecialchars_decode(...)' y 'stripcslashes(...)' o no. [Por defecto NO]
Devuelve
string con el texto de todos los nodos tipo 'textNode' de este elemento y sus hijos.
getType ( )

Metodo para leer el tipo DOM de este elemento.

Devuelve
String con el tipo de este elemento DOM.

Implementa DOM_Interface.

importConfINI ( $confFile = null )

Importar las configuraciones desde el archivo config.ini, Utiliza la seccion del INI [CONF_SEC].

Si no se entrega parametro de ruta se utilizara el archivo de configuracion por defecto ('config.ini') en la ruta del pakete.

El archivo INI de configuracion debe tener una estructura INI adecuada, con sus secciones validas y sus variables y valores:
Caracteres exclusivamente AlfaNumericos, o sino, encerrados entre comillas dobles ' " ', Lineas de Comentarios inician con punto y coma ' ; ', …

Debe contener como minimo las siguientes secciones: [PK_SEC] : Seccion para identificacion del pakete. [CONSTS_SEC] : Seccion para las constantes de la clase (PATH_CLASS_DOM, CONF_INI_FILE_DOM, ...) [CONF_SEC] : Seccion para las variables de configuracion (TAG, _text,...)

Para poder simular el incluir comillas dobles, se ha definido un 'token' (QUOTE), que puede utilizarse dentro del INI.
Parámetros
string $confFile (OPCIONAL, DEFAULT=NULL) La ruta completa al archivo de configuracion INI a cargar.
Devuelve
DOM_element $this este elemento (DOM) con sus atributos correspondientes.
Ver también
DOM_Interface::getConfiguration()
DOM_Interface::setConfiguration()

Implementa DOM_Interface.

static objJSON2DOM_element | ( | $objectJSON,
 |  | $return = true,
 |  | $base64values = true
 | ) |
static

Metodo estatico para construir un objeto DOM a la imagen y semejanza del objeto JSON entregado que deberia representar otro DOM_element con hijos, atributos, y caracteristicas propias.

NI QUE DECIR TIENE QUE EL OBJETO JSON ENTREGADO DEBE SER UN FIEL REFLEJO DE ALGUN ELEMENTO DE ESTA CLASE, NORMALMENTE SE OBTENDRA DECODIFICANDO EL RETORNO DE LA FUNCION toJSON(); (json_decode(...->toJSON();))

Parámetros
JSON | $objectJSON | Es un objeto creado con una cadena JSON.
boolean | $return | Expresa si retornar (TRUE) el objeto creado o imprimirlo (FALSE).
boolean | $base64values | Indica si codificar los textos en 'base64' o no.
Devuelve
DOM_element El elemento (DOM_element) creado equivalente al objeto entregado o NULL en caso de impresion.
removeChild | ( | $child,
 |  | $grandchildren = true
 | ) |

Metodo para eliminar el hijo del elemento que sea el mismo ('equalsExact') que el pasado por parametro, Retorna el numero de elementos eliminados, Este metodo puede ser recursivo, el segundo parametro (por defecto TRUE) indica si comprobar recursivamente en nietos...

CAUTION!: USE RECURSIVE FUNCTION!!

Parámetros
DOM_element | $child | El objeto hijo a eliminar.
boolean | $grandchildren | TRUE(DEFAULT)=elimina recursivamente, FALSE=solo mira en los hijos directos.
Devuelve
DOM_element $this este elemento (DOM).
Ver también
DOM_Interface::removeChildrenAll()
DOM_Interface::removeChildByKey()
DOM_Interface::removeChildrenByTag()
DOM_Interface::removeChildrenByType()

Implementa DOM_Interface.

removeChildByKey | ( | $key,
 |  | $grandchildren = true
 | ) |

Metodo para eliminar el hijo del elemento que contengan la misma clave que la pasada por parametro, Este metodo es recursivo, el segundo parametro (por defecto TRUE) indica si comprobar recursivamente en nietos...

CAUTION!: USE RECURSIVE FUNCTION!!

Parámetros
string | $key | La clave del elemento a eliminar.
boolean | $grandchildren | TRUE=elimina recursivamente, FALSE=solo mira en los hijos directos.
Devuelve
DOM_element $this este elemento (DOM).
Ver también
DOM_Interface::removeChild()
DOM_Interface::removeChildrenAll()
DOM_Interface::removeChildrenByTag()
DOM_Interface::removeChildrenByType()

Implementa DOM_Interface.

removeChildrenAll ( )

Elimina todos sus hijos (ELIMINA EL CONTENIDO ENTERO DE ESTE ELEMENTO).

Devuelve
DOM_element $this este elemento (DOM).
Ver también
DOM_Interface::removeChild()
DOM_Interface::removeChildByKey()
DOM_Interface::removeChildrenByTag()
DOM_Interface::removeChildrenByType()

Implementa DOM_Interface.

removeChildrenByTag | ( | $tag,
 |  | $grandchildren = true
 | ) |

Metodo para eliminar los hijos del elemento que contengan la misma etiqueta (TAG) que la pasada por parametro, Retorna el numero de elementos eliminados, Este metodo es recursivo, el segundo parametro (por defecto TRUE) indica si comprobar recursivamente en nietos...

CAUTION!: USE RECURSIVE FUNCTION!!

Parámetros
string | $tag | La etiqueta (TAG) del elemento a eliminar.
boolean | $grandchildren | TRUE=elimina recursivamente, FALSE=solo mira en los hijos directos.
Devuelve
DOM_element $this este elemento (DOM).
Ver también
DOM_Interface::removeChild()
DOM_Interface::removeChildrenAll()
DOM_Interface::removeChildByKey()
DOM_Interface::removeChildrenByType()

Implementa DOM_Interface.

removeChildrenByType | ( | $type,
 |  | $grandchildren = true
 | ) |

Metodo para eliminar los hijos del elemento que sean del mismo tipo (Type) que el pasado por parametro, Retorna el numero de elementos eliminados, Este metodo es recursivo, el segundo parametro (por defecto TRUE) indica si comprobar recursivamente en nietos...

CAUTION!: USE RECURSIVE FUNCTION!!

Parámetros
string | $tag | La etiqueta (TAG) del elemento a eliminar.
boolean | $grandchildren | TRUE=elimina recursivamente, FALSE=solo mira en los hijos directos.
Devuelve
DOM_element $this este elemento (DOM).
Ver también
DOM_Interface::removeChild()
DOM_Interface::removeChildrenAll()
DOM_Interface::removeChildByKey()
DOM_Interface::removeChildrenByTag()

Implementa DOM_Interface.

setChildren ( array $children = null )

Metodo para establecer los hijos al elemento DOM. Estos hijos a su vez deben ser elementos DOM.

Parámetros
$children Array Elementos del DOM.
Devuelve
DOM_element $this este elemento (DOM).
Ver también
DOM_Interface::addChild()
DOM_Interface::addChildren()

Implementa DOM_Interface.

setConfiguration ( array $conf )

Grabar la configuracion de este elemento

Parámetros
array $conf Array asociativo de variables de configuracion en formato 'clave=valor'
Devuelve
DOM_element $this este elemento (DOM).
Ver también
DOM_Interface::getConfiguration()
DOM_Interface::importConfINI()

Implementa DOM_Interface.

setKey ( string $key = null )

Metodo para establecer la clave de este elemento DOM.

Parámetros
$key string clave del elemento.
Devuelve
DOM_element $this este elemento (DOM).

Implementa DOM_Interface.

setText ( $text )

Agreaga un hijo de texto (textNode) a este elemento DOM, eliminando los hijos tipo 'textNode' que tubiese

Parámetros
string $text para este elemento.
Devuelve
string con el texto anterior.
toHTML ( )

Metodo para retornar la cadena que representa el HTML de este elemento DOM con sus atributos, y los de sus hijos, correspondientes.

Devuelve
String HTML de este elemento (DOM) con sus atributos correspondientes.

Implementa DOM_Interface.

toJSON | ( | $return = true,
 |  | $base64values = true
 | ) |

Metodo para retornar la cadena JSON que representa este elemento DOM con sus hijos y con sus atributos, y los de sus hijos, correspondientes.

RECOMENDADO: Aporta un segundo parametro para codificar todos los valores (no las claves) en 'base64', (DEFECTO=true), asi podriamos evitar el problema de los tipos de codificacion empleados (JSON solo admite UTF-8).

NO UTILIZA LA FUNCION PHP 'json_encode(..)'

<del>Utiliza las siguientes constantes PHP 5.3: JSON_HEX_QUOT && JSON_HEX_TAG && JSON_HEX_AMP && JSON_HEX_APOS</del>

Parámetros
boolean | $return | Indica si retornar el resultado (TRUE) o imprimirlo (FALSE).
boolean | $base64values | Indica si codificar los textos en 'base64' o no.
Devuelve
String JSON de este elemento (DOM) con sus atributos correspondientes o NULL en caso de desear imprimirlo.

Implementa DOM_Interface.

tryingWrite ( $arg = "" )
protected

:OVERRIDE-PARENT:

Notifica una accion de escritura al objeto; Si es de solo-lectura lanzara una Excepcion.

Devuelve
boolean TRUE=OK, FALSE=throw DOMBasicElementReadOnlyException()
Excepciones
DOMBasicElementReadOnlyException;

Documentación de los campos

$AVISO_GET =false
protected

¿ Lanzar Aviso cuando se lee un atributo que no existe ?

const AVISO_SINGLETON =true

¿ Lanzar Aviso cuando se intenta tomar una instancia estatica mediante el 'Patron SINGLETON' sin estar permitida por ''PATRON SINGLETON' ?

const PATRON_SINGLETON =true

¿ Permitir el patron SINGLETON ?

La documentación para esta clase fue generada a partir del siguiente fichero:
  • objetosPHP/DOM_element.php


DOMbasic: Referencia de la Interfaz DOM_Interface

DOMBasic es un Framework PHP para la creación de elementos DOM que generan contenido HTML dinámico y permite su modificación 'al vuelo' (Websites). Está escrito entéramente en PHP y sigue el paradigma POO.
  • Página principal
  • Namespaces
  • Estructuras de Datos
  • Estructura de datos
  • Índice de estructura de datos
  • Jerarquía de la clase
  • Campos de datos
Métodos públicos
Referencia de la Interfaz DOM_Interface
Diagrama de herencias de DOM_Interface
DOM_element DOM_textNode

Métodos públicos

setKey (string $key=null)
getKey ()
getTag ()
getOpenTag ()
getCloseTag ()
getType ()
getDesc ()
addChild (DOM_element $child=null)
addChildren (array $children=null)
setChildren (array $children=null)
getChildren ()
getChildrenAll ()
getChildByKey ($key, $grandchildren=true)
getChildrenByTag ($tag, $grandchildren=true)
getChildrenByType ($type, $grandchildren=true)
removeChild ($child, $grandchildren=true)
removeChildrenAll ()
removeChildByKey ($key, $grandchildren=true)
removeChildrenByTag ($tag, $grandchildren=true)
removeChildrenByType ($type, $grandchildren=true)
equalsType ($objDOM)
toHTML ()
toJSON ($return=true, $base64values=true)
fromJSON ($json)
getConfiguration ()
setConfiguration (array $conf)
importConfINI ($confFile=null)

Descripción detallada

Interfaz para los elementos del DOM. Admite CONCATENACION DE METODOS mediante el retorno de la construccion '$this' en todos los metodos 'NO-GETTER'

Documentación de las funciones miembro

addChild ( DOM_element $child = null )

Metodo para agregar un hijo al elemento DOM.

Parámetros
$child Elemento DOM.
Devuelve
DOM_element $this este elemento (DOM).
Ver también
DOM_Interface::addChildren()
DOM_Interface::setChildren()

Implementado en DOM_element.

addChildren ( array $children = null )

Metodo para agregar un array de hijos de elementos DOM, al ya existente.

Parámetros
$child Elemento DOM.
Devuelve
DOM_element $this este elemento (DOM).
Ver también
DOM_Interface::addChild()
DOM_Interface::setChildren()

Implementado en DOM_element.

equalsType ( $objDOM )

Compara si otro objeto es del mismo TIPO que este (no si es el mismo)

Parámetros
DOM_element $objDOM Algun objeto instancia de esta Clase
Devuelve
boolean

Implementado en DOM_element.

fromJSON ( $json )

Metodo para reconstruir este objeto a la imagen y semejanza de la cadena JSON entregada que deberia representar otro DOM_element con hijos, atributos, y caracteristicas propias.

Detecta AUTOMATICAMENTE si el objeto se codifico con 'base64'.

UTILIZA LA FUNCION PHP 'json_decode()' con parametros por defecto.

Parámetros
string $json La cadena json que representa un objeto DOM_element. Esta cadena se construye con la funcion contraria toJSON().
Devuelve
DOM_element El elemento actual (this) reconstruido a la forma del objeto de entrada.

Implementado en DOM_element.

getChildByKey | ( | $key,
 |  | $grandchildren = true
 | ) |

Metodo para buscar y retornar un hijo del elemento que contenga la misma clave que la pasada por parametro, este metodo es recursivo pero retorna el primer elemento que concuerde su clave, el segundo parametro (por defecto TRUE) indica si comprobar recursivamente en nietos...

CAUTION!: USE RECURSIVE FUNCTION!!

Parámetros
string | $key | La clave del elemento a buscar.
boolean | $grandchildren | TRUE=elimina recursivamente, FALSE=solo mira en los hijos directos.
Devuelve
DOM_element Elemento si es que se encuentra, sino null.
Ver también
DOM_Interface::getChildrenByTag()
DOM_Interface::getChildrenByType()
DOM_Interface::getChildren()
DOM_Interface::getChildrenAll()

Implementado en DOM_element.

getChildren ( )

Metodo para retornar el array de todos los hijos del elemento DOM. Similar a DOM_Interface::getChildrenAll()

Devuelve
Array de elementos (DOM) con sus atributos correspondientes.
Ver también
DOM_Interface::getChildrenAll()
DOM_Interface::getChildByKey()
DOM_Interface::getChildrenByTag()
DOM_Interface::getChildrenByType()

Implementado en DOM_element.

getChildrenAll ( )

Metodo para retornar un array con todos los hijos de forma recursiva (nietos, bisnietos, ...) del elemento DOM. Similar a DOM_Interface::getChildren()

Devuelve
Array de elementos (DOM) con sus atributos correspondientes.
Ver también
DOM_Interface::getChildren()
DOM_Interface::getChildByKey()
DOM_Interface::getChildrenByTag()
DOM_Interface::getChildrenByType()

Implementado en DOM_element.

getChildrenByTag | ( | $tag,
 |  | $grandchildren = true
 | ) |

Metodo para buscar y retornar un array de hijos del elemento que contengan la misma etiqueta (TAG) que la pasada por parametro, el segundo parametro (por defecto TRUE) indica si comprobar recursivamente en nietos...

CAUTION!: RECURSIVE FUNCTION!!

Parámetros
string | $tag | La etiqueta (TAG) del elemento a buscar.
boolean | $grandchildren | TRUE=elimina recursivamente, FALSE=solo mira en los hijos directos.
Devuelve
array(DOM_element) si es que se encuentran, sino un array vacio.
Ver también
DOM_Interface::getChildByKey()
DOM_Interface::getChildrenByType()
DOM_Interface::getChildren()
DOM_Interface::getChildrenAll()

Implementado en DOM_element.

getChildrenByType | ( | $type,
 |  | $grandchildren = true
 | ) |

Metodo para buscar y retornar un array de hijos del elemento que sean del mismo tipo (TYPE) que el pasado por parametro, el segundo parametro (por defecto TRUE) indica si comprobar recursivamente en nietos...

CAUTION!: RECURSIVE FUNCTION!!

Parámetros
string | $type | El tipo (TYPE) del elemento a buscar.
boolean | $grandchildren | TRUE=elimina recursivamente, FALSE=solo mira en los hijos directos.
Devuelve
array(DOM_element) si es que se encuentran, sino un array vacio.
Ver también
DOM_Interface::getChildByKey()
DOM_Interface::getChildrenByTag()
DOM_Interface::getChildren()
DOM_Interface::getChildrenAll()

Implementado en DOM_element.

getCloseTag ( )

Metodo para leer la etiqueta HTML de cierre construida para este elemento, con sus atributos incluidos.

NOTE: Existen elementos que deben establecer la suya propia, como los elementos autocontendios (<img />, </br >, ...) o elementos sin etiqueta como 'textNode'.

Devuelve
String con la etiqueta HTML de cierre.

Implementado en DOM_element.

getConfiguration ( )

Leer la configuracion de este elemento

Devuelve
array
Ver también
DOM_Interface::setConfiguration()
DOM_Interface::importConfINI()

Implementado en DOM_element.

getDesc ( )

Metodo para leer la descripcion DOM de este elemento.

Devuelve
String con la descripcion de este elemento DOM.

Implementado en DOM_element.

getKey ( )

Metodo para tomar la clave del elemento.

Devuelve
String con la clave de este elemento.

Implementado en DOM_element.

getOpenTag ( )

Metodo para leer la etiqueta HTML de apertura construida para este elemento, con sus atributos incluidos.

Devuelve
String con la etiqueta HTML de apertura.

Implementado en DOM_element y DOM_textNode.

getTag ( )

Metodo para leer la etiqueta DOM de este elemento.

Devuelve
String con la etiqueta de este elemento DOM.

Implementado en DOM_element.

getType ( )

Metodo para leer el tipo DOM de este elemento.

Devuelve
String con el tipo de este elemento DOM.

Implementado en DOM_element.

importConfINI ( $confFile = null )

Importar las configuraciones desde el archivo config.ini, Utiliza la seccion del INI [CONF_SEC].

Si no se entrega parametro de ruta se utilizara el archivo de configuracion por defecto ('config.ini') en la ruta del pakete.

El archivo INI de configuracion debe tener una estructura INI adecuada, con sus secciones validas y sus variables y valores:
Caracteres exclusivamente AlfaNumericos, o sino, encerrados entre comillas dobles ' " ', Lineas de Comentarios inician con punto y coma ' ; ', …

Debe contener como minimo las siguientes secciones: [PK_SEC] : Seccion para identificacion del pakete. [CONSTS_SEC] : Seccion para las constantes de la clase (PATH_CLASS_DOM, CONF_INI_FILE_DOM, ...) [CONF_SEC] : Seccion para las variables de configuracion (TAG, _text,...)

Para poder simular el incluir comillas dobles, se ha definido un 'token' (QUOTE), que puede utilizarse dentro del INI.
Parámetros
string $confFile (OPCIONAL, DEFAULT=NULL) La ruta completa al archivo de configuracion INI a cargar.
Devuelve
DOM_element $this este elemento (DOM) con sus atributos correspondientes.
Ver también
DOM_Interface::getConfiguration()
DOM_Interface::setConfiguration()

Implementado en DOM_element.

removeChild | ( | $child,
 |  | $grandchildren = true
 | ) |

Metodo para eliminar el hijo del elemento que sea el mismo ('equalsExact') que el pasado por parametro, Retorna el numero de elementos eliminados, Este metodo puede ser recursivo, el segundo parametro (por defecto TRUE) indica si comprobar recursivamente en nietos...

CAUTION!: USE RECURSIVE FUNCTION!!

Parámetros
DOM_element | $child | El objeto hijo a eliminar.
boolean | $grandchildren | TRUE(DEFAULT)=elimina recursivamente, FALSE=solo mira en los hijos directos.
Devuelve
DOM_element $this este elemento (DOM).
Ver también
DOM_Interface::removeChildrenAll()
DOM_Interface::removeChildByKey()
DOM_Interface::removeChildrenByTag()
DOM_Interface::removeChildrenByType()

Implementado en DOM_element.

removeChildByKey | ( | $key,
 |  | $grandchildren = true
 | ) |

Metodo para eliminar el hijo del elemento que contengan la misma clave que la pasada por parametro, Este metodo es recursivo, el segundo parametro (por defecto TRUE) indica si comprobar recursivamente en nietos...

CAUTION!: USE RECURSIVE FUNCTION!!

Parámetros
string | $key | La clave del elemento a eliminar.
boolean | $grandchildren | TRUE=elimina recursivamente, FALSE=solo mira en los hijos directos.
Devuelve
DOM_element $this este elemento (DOM).
Ver también
DOM_Interface::removeChild()
DOM_Interface::removeChildrenAll()
DOM_Interface::removeChildrenByTag()
DOM_Interface::removeChildrenByType()

Implementado en DOM_element.

removeChildrenAll ( )

Elimina todos sus hijos (ELIMINA EL CONTENIDO ENTERO DE ESTE ELEMENTO).

Devuelve
DOM_element $this este elemento (DOM).
Ver también
DOM_Interface::removeChild()
DOM_Interface::removeChildByKey()
DOM_Interface::removeChildrenByTag()
DOM_Interface::removeChildrenByType()

Implementado en DOM_element.

removeChildrenByTag | ( | $tag,
 |  | $grandchildren = true
 | ) |

Metodo para eliminar los hijos del elemento que contengan la misma etiqueta (TAG) que la pasada por parametro, Retorna el numero de elementos eliminados, Este metodo es recursivo, el segundo parametro (por defecto TRUE) indica si comprobar recursivamente en nietos...

CAUTION!: USE RECURSIVE FUNCTION!!

Parámetros
string | $tag | La etiqueta (TAG) del elemento a eliminar.
boolean | $grandchildren | TRUE=elimina recursivamente, FALSE=solo mira en los hijos directos.
Devuelve
DOM_element $this este elemento (DOM).
Ver también
DOM_Interface::removeChild()
DOM_Interface::removeChildrenAll()
DOM_Interface::removeChildByKey()
DOM_Interface::removeChildrenByType()

Implementado en DOM_element.

removeChildrenByType | ( | $type,
 |  | $grandchildren = true
 | ) |

Metodo para eliminar los hijos del elemento que sean del mismo tipo (Type) que el pasado por parametro, Retorna el numero de elementos eliminados, Este metodo es recursivo, el segundo parametro (por defecto TRUE) indica si comprobar recursivamente en nietos...

CAUTION!: USE RECURSIVE FUNCTION!!

Parámetros
string | $tag | La etiqueta (TAG) del elemento a eliminar.
boolean | $grandchildren | TRUE=elimina recursivamente, FALSE=solo mira en los hijos directos.
Devuelve
DOM_element $this este elemento (DOM).
Ver también
DOM_Interface::removeChild()
DOM_Interface::removeChildrenAll()
DOM_Interface::removeChildByKey()
DOM_Interface::removeChildrenByTag()

Implementado en DOM_element.

setChildren ( array $children = null )

Metodo para establecer los hijos al elemento DOM. Estos hijos a su vez deben ser elementos DOM.

Parámetros
$children Array Elementos del DOM.
Devuelve
DOM_element $this este elemento (DOM).
Ver también
DOM_Interface::addChild()
DOM_Interface::addChildren()

Implementado en DOM_element.

setConfiguration ( array $conf )

Grabar la configuracion de este elemento

Parámetros
array $conf Array asociativo de variables de configuracion en formato 'clave=valor'
Devuelve
DOM_element $this este elemento (DOM).
Ver también
DOM_Interface::getConfiguration()
DOM_Interface::importConfINI()

Implementado en DOM_element.

setKey ( string $key = null )

Metodo para establecer la clave de este elemento DOM.

Parámetros
$key string clave del elemento.
Devuelve
DOM_element $this este elemento (DOM).

Implementado en DOM_element.

toHTML ( )

Metodo para retornar la cadena que representa el HTML de este elemento DOM con sus atributos, y los de sus hijos, correspondientes.

Devuelve
String HTML de este elemento (DOM) con sus atributos correspondientes.

Implementado en DOM_element.

toJSON | ( | $return = true,
 |  | $base64values = true
 | ) |

Metodo para retornar la cadena JSON que representa este elemento DOM con sus hijos y con sus atributos, y los de sus hijos, correspondientes.

RECOMENDADO: Aporta un segundo parametro para codificar todos los valores (no las claves) en 'base64', (DEFECTO=true), asi podriamos evitar el problema de los tipos de codificacion empleados (JSON solo admite UTF-8).

NO UTILIZA LA FUNCION PHP 'json_encode(..)'

<del>Utiliza las siguientes constantes PHP 5.3: JSON_HEX_QUOT && JSON_HEX_TAG && JSON_HEX_AMP && JSON_HEX_APOS</del>

Parámetros
boolean | $return | Indica si retornar el resultado (TRUE) o imprimirlo (FALSE).
boolean | $base64values | Indica si codificar los textos en 'base64' o no.
Devuelve
String JSON de este elemento (DOM) con sus atributos correspondientes o NULL en caso de desear imprimirlo.

Implementado en DOM_element.

La documentación para este interfaz fue generada a partir del siguiente fichero:
  • objetosPHP/DOM_Interface.php


DOMbasic: Referencia de la Clase DOM_textNode

DOMBasic es un Framework PHP para la creación de elementos DOM que generan contenido HTML dinámico y permite su modificación 'al vuelo' (Websites). Está escrito entéramente en PHP y sigue el paradigma POO.
  • Página principal
  • Namespaces
  • Estructuras de Datos
  • Estructura de datos
  • Índice de estructura de datos
  • Jerarquía de la clase
  • Campos de datos
Métodos públicos | Métodos públicos estáticos | Campos de datos | Atributos protegidos | Atributos protegidos estáticos
Referencia de la Clase DOM_textNode
Diagrama de herencias de DOM_textNode
DOM_element DOM_attribs DOM_Interface

Métodos públicos

__construct ($key=null)
getOpenTag ()
setText ($text)
- Métodos públicos heredados desde DOM_element
__construct ($key=null)
__clone ()
__unset ($child)
__toString ()
reinicializar ()
setReadOnly ($readOnly)
getReadOnly ()
setKey (string $key=null)
getKey ()
getTag ()
setTag ($tag)
getOpenTag ()
getCloseTag ()
getType ()
getDesc ()
clearText ()
setText ($text)
addText ($text)
getTextAll ($filter=false)
getText ($filter=false)
addChild (DOM_element $child=null)
addChildren (array $children=null)
setChildren (array $children=null)
getChildren ()
getChildrenAll ()
getChildByKey ($key, $grandchildren=true)
getChildrenByTag ($tag, $grandchildren=true)
getChildrenByType ($type, $grandchildren=true)
removeChild ($child, $grandchildren=true)
removeChildrenAll ()
removeChildByKey ($key, $grandchildren=true)
removeChildrenByTag ($tag, $grandchildren=true)
removeChildrenByType ($type, $grandchildren=true)
equals ($objDOM)
equalsType ($objDOM)
toHTML ()
toJSON ($return=true, $base64values=true)
fromJSON ($json)
fromDOM_element (DOM_element $dom)
attribsToURL ($encode=self::ENCODE_RFC_1738)
attribsFromURL ($strURL)
getConfiguration ()
setConfiguration (array $conf)
importConfINI ($confFile=null)
- Métodos públicos heredados desde DOM_attribs
__construct ($asocArrayAttribs=null)
setReadOnly ($readOnly)
getReadOnly ()
reinicializar ()
__get ($attrib)
__set ($attrib, $value)
__isset ($attrib)
__unset ($attrib)
offsetExists ($attrib)
offsetGet ($attrib)
offsetSet ($attrib, $value)
offsetUnset ($attrib)
getIterator ()
setAttribs ($asocArrayAttribs)
getAttribs ()
getAttribsStr ()
addAttrib ($attrib, $valorAttrib)
addAttribs ($arrayAttribs)
removeAttrib ($attrib)
removeAttribs ($arrayAttribs)
clearAttribs ()
countAttrs ()
equals ($objAttribs)
__toString ()
toJSON ($return=true, $base64values=true)
fromJSON ($arrJSON)
setEjemplo ()

Métodos públicos estáticos

static | getInstance ()
- Métodos públicos estáticos heredados desde DOM_element
static | getInstance ()
static | getDTD (int $dtd)
static | objJSON2DOM_element ($objectJSON, $return=true, $base64values=true)
- Métodos públicos estáticos heredados desde DOM_attribs
static | arrayFromURL ($strURLquery)
static | filtrarStrJSON ($str="")
static | writeLog ($mensaje, $trace)

Campos de datos

const | N_C = __CLASS__
- Campos de datos heredados desde DOM_element
const | N_C = __CLASS__
const | PATRON_SINGLETON =true
const | AVISO_SINGLETON =true
- Campos de datos heredados desde DOM_attribs
const | N_C = __CLASS__
const | ENCODE_RFC_1738 ="RFC_1738"
const | ENCODE_RFC_3986 ="RFC_3986"

Atributos protegidos

$TAG = ""
$TYPE = "textNode"
$DESC = "inline DOM text element"
$OPEN_TAG_LEFT =""
$OPEN_TAG_RIGHT =""
$CLOSE_TAG_LEFT =""
$CLOSE_TAG_RIGHT =""
$_text =""
- Atributos protegidos heredados desde DOM_element
$_READ_ONLY =false
$TAG = ""
$TYPE = "container"
$DESC = "DOM's container element"
$OPEN_TAG_LEFT ="<"
$OPEN_TAG_RIGHT =">"
$CLOSE_TAG_LEFT ="</"
$CLOSE_TAG_RIGHT =">"
$AVISO_GET =false
$_key =""
$_text =""
$_children =array()
- Atributos protegidos heredados desde DOM_attribs
$_READ_ONLY =false
$AVISO_GET =false
$_attribs =array()

Atributos protegidos estáticos

static | $instance
- Atributos protegidos estáticos heredados desde DOM_element
static | $DTD_DOCTYPE_HTML =0
static | $DTD_DOCTYPE_XHTML_TRANSITIONAL =10
static | $DTD_DOCTYPE_XHTML_STRICT =10
static | $DTD_XML_1_0 =20
static | $LINE_BREAK ="\n"
static | $instance

Otros miembros heredados

- Métodos protegidos heredados desde DOM_element
tryingWrite ($arg="")
- Métodos protegidos heredados desde DOM_attribs
tryingWrite ($arg="")
toURL ($encode=self::ENCODE_RFC_3986)
fromURL ($strURLquery)

Descripción detallada

Clase para crear objetos de NODOS DE TEXTO para elementos del DOM, utiles para insertar texto 'innerHTML' dentro de los elementos del DOM.

Documentación de las funciones miembro

static getInstance ( )
static

PATRON SINGLETON. Tomar una instancia de forma estatica.
$txt = DOM_textNode::getInstance();

getOpenTag ( )

Metodo para leer la etiqueta HTML de apertura construida para este elemento, con sus atributos incluidos.

Devuelve
String con la etiqueta HTML de apertura.

Implementa DOM_Interface.

setText ( $text )

Metodo para establecer el texto de este elemento DOM.

Parámetros
string $text para este elemento.
Devuelve
string con el texto anterior.

Documentación de los campos

$_text =""
protected

Texto que contiene este elemento.

La documentación para esta clase fue generada a partir del siguiente fichero:
  • objetosPHP/DOM_textNode.php


DOMbasic: Referencia de la Clase DOMBasicAttribNotFoundException

DOMBasic es un Framework PHP para la creación de elementos DOM que generan contenido HTML dinámico y permite su modificación 'al vuelo' (Websites). Está escrito entéramente en PHP y sigue el paradigma POO.
  • Página principal
  • Namespaces
  • Estructuras de Datos
  • Estructura de datos
  • Índice de estructura de datos
  • Jerarquía de la clase
  • Campos de datos
Métodos públicos
Referencia de la Clase DOMBasicAttribNotFoundException
Diagrama de herencias de DOMBasicAttribNotFoundException
DOMBasicException

Métodos públicos

__construct ($name)
- Métodos públicos heredados desde DOMBasicException
__construct ($message)

Otros miembros heredados

- Campos de datos heredados desde DOMBasicException
$originalMessage

Documentación del constructor y destructor

__construct ( $name )

Constructs a new DOMBasicAttribNotFoundException for the attrib $name.

Parámetros
string $name The name of the attrib
La documentación para esta clase fue generada a partir del siguiente fichero:
  • objetosPHP/exceptions/DOMBasicAttribNotFoundException.php


DOMbasic: Referencia de la Clase DOMBasicAttribReadOnlyException

DOMBasic es un Framework PHP para la creación de elementos DOM que generan contenido HTML dinámico y permite su modificación 'al vuelo' (Websites). Está escrito entéramente en PHP y sigue el paradigma POO.
  • Página principal
  • Namespaces
  • Estructuras de Datos
  • Estructura de datos
  • Índice de estructura de datos
  • Jerarquía de la clase
  • Campos de datos
Métodos públicos | Campos de datos
Referencia de la Clase DOMBasicAttribReadOnlyException
Diagrama de herencias de DOMBasicAttribReadOnlyException
DOMBasicException

Métodos públicos

__construct ($name, $mode)
- Métodos públicos heredados desde DOMBasicException
__construct ($message)

Campos de datos

const | READ = 1
const | WRITE = 2
- Campos de datos heredados desde DOMBasicException
$originalMessage

Documentación del constructor y destructor

__construct | ( | $name,
 |  | $mode
 | ) |

Constructs a new DOMBasicAttribReadOnlyException for the attrib $name.

Parámetros
string | $name | The name of the attrib.
int | $mode | The mode of the attrib that is allowed (::READ or ::WRITE).

Documentación de los campos

const READ = 1

Used when the attrib is read-only.

const WRITE = 2

Used when the attrib is write-only.

La documentación para esta clase fue generada a partir del siguiente fichero:
  • objetosPHP/exceptions/DOMBasicAttribReadOnlyException.php


DOMbasic: Referencia de la Clase DOMBasicAutoloadException

DOMBasic es un Framework PHP para la creación de elementos DOM que generan contenido HTML dinámico y permite su modificación 'al vuelo' (Websites). Está escrito entéramente en PHP y sigue el paradigma POO.
  • Página principal
  • Namespaces
  • Estructuras de Datos
  • Estructura de datos
  • Índice de estructura de datos
  • Jerarquía de la clase
  • Campos de datos
Métodos públicos
Referencia de la Clase DOMBasicAutoloadException
Diagrama de herencias de DOMBasicAutoloadException
DOMBasicException

Métodos públicos

__construct ($className, $files, $dirs)
- Métodos públicos heredados desde DOMBasicException
__construct ($message)

Otros miembros heredados

- Campos de datos heredados desde DOMBasicException
$originalMessage

Documentación del constructor y destructor

__construct | ( | $className,
 |  | $files,
 |  | $dirs
 | ) |

Constructs a new DOMBasicAutoloadException for the $className that was searched for in the autoload files $fileNames from the directories specified in $dirs.

Parámetros
string | $className
array(string) | $files
array(DOMBasicRepositoryDirectory) | $dirs
La documentación para esta clase fue generada a partir del siguiente fichero:
  • objetosPHP/exceptions/DOMBasicAutoloadException.php


DOMbasic: Referencia de la Clase DOMBasicElementNotFoundException

DOMBasic es un Framework PHP para la creación de elementos DOM que generan contenido HTML dinámico y permite su modificación 'al vuelo' (Websites). Está escrito entéramente en PHP y sigue el paradigma POO.
  • Página principal
  • Namespaces
  • Estructuras de Datos
  • Estructura de datos
  • Índice de estructura de datos
  • Jerarquía de la clase
  • Campos de datos
Métodos públicos
Referencia de la Clase DOMBasicElementNotFoundException
Diagrama de herencias de DOMBasicElementNotFoundException
DOMBasicException

Métodos públicos

__construct ($name)
- Métodos públicos heredados desde DOMBasicException
__construct ($message)

Otros miembros heredados

- Campos de datos heredados desde DOMBasicException
$originalMessage

Documentación del constructor y destructor

__construct ( $name )

Constructs a new DOMBasicElementNotFoundException for the element $name.

Parámetros
string $name The name of the element
La documentación para esta clase fue generada a partir del siguiente fichero:
  • objetosPHP/exceptions/DOMBasicElementNotFoundException.php


DOMbasic: Referencia de la Clase DOMBasicElementReadOnlyException

DOMBasic es un Framework PHP para la creación de elementos DOM que generan contenido HTML dinámico y permite su modificación 'al vuelo' (Websites). Está escrito entéramente en PHP y sigue el paradigma POO.
  • Página principal
  • Namespaces
  • Estructuras de Datos
  • Estructura de datos
  • Índice de estructura de datos
  • Jerarquía de la clase
  • Campos de datos
Métodos públicos | Campos de datos
Referencia de la Clase DOMBasicElementReadOnlyException
Diagrama de herencias de DOMBasicElementReadOnlyException
DOMBasicException

Métodos públicos

__construct ($keyTag, $mode)
- Métodos públicos heredados desde DOMBasicException
__construct ($message)

Campos de datos

const | READ = 1
const | WRITE = 2
- Campos de datos heredados desde DOMBasicException
$originalMessage

Documentación del constructor y destructor

__construct | ( | $keyTag,
 |  | $mode
 | ) |

Constructs a new DOMBasicElementReadOnlyException for the element $keyTag.

Parámetros
string | $keyTag | The key and TAG of the element.
int | $mode | The mode of the element that is allowed (::READ or ::WRITE).

Documentación de los campos

const READ = 1

Used when the element is read-only.

const WRITE = 2

Used when the element is write-only.

La documentación para esta clase fue generada a partir del siguiente fichero:
  • objetosPHP/exceptions/DOMBasicElementReadOnlyException.php


DOMbasic: Referencia de la Clase DOMBasicException

DOMBasic es un Framework PHP para la creación de elementos DOM que generan contenido HTML dinámico y permite su modificación 'al vuelo' (Websites). Está escrito entéramente en PHP y sigue el paradigma POO.
  • Página principal
  • Namespaces
  • Estructuras de Datos
  • Estructura de datos
  • Índice de estructura de datos
  • Jerarquía de la clase
  • Campos de datos
Métodos públicos | Campos de datos
Referencia de la Clase DOMBasicException
Diagrama de herencias de DOMBasicException
DOMBasicAttribNotFoundException DOMBasicAttribReadOnlyException DOMBasicAutoloadException DOMBasicElementNotFoundException DOMBasicElementReadOnlyException DOMBasicSingletonException DOMBasicValueException

Métodos públicos

__construct ($message)

Campos de datos

$originalMessage

Documentación del constructor y destructor

__construct ( $message )

Constructs a new DOMBasicException with $message

Parámetros
string $message

Documentación de los campos

$originalMessage

Original message, before escaping

La documentación para esta clase fue generada a partir del siguiente fichero:
  • objetosPHP/exceptions/DOMBasicException.php


DOMbasic: Referencia de la Clase DOMBasicSingletonException

DOMBasic es un Framework PHP para la creación de elementos DOM que generan contenido HTML dinámico y permite su modificación 'al vuelo' (Websites). Está escrito entéramente en PHP y sigue el paradigma POO.
  • Página principal
  • Namespaces
  • Estructuras de Datos
  • Estructura de datos
  • Índice de estructura de datos
  • Jerarquía de la clase
  • Campos de datos
Métodos públicos
Referencia de la Clase DOMBasicSingletonException
Diagrama de herencias de DOMBasicSingletonException
DOMBasicException

Métodos públicos

__construct ()
- Métodos públicos heredados desde DOMBasicException
__construct ($message)

Otros miembros heredados

- Campos de datos heredados desde DOMBasicException
$originalMessage

Documentación del constructor y destructor

__construct ( )

Constructs a new DOMBasicSingletonException for the elements and attribs.

La documentación para esta clase fue generada a partir del siguiente fichero:
  • objetosPHP/exceptions/DOMBasicSingletonException.php


DOMbasic: Referencia de la Clase DOMBasicValueException

DOMBasic es un Framework PHP para la creación de elementos DOM que generan contenido HTML dinámico y permite su modificación 'al vuelo' (Websites). Está escrito entéramente en PHP y sigue el paradigma POO.
  • Página principal
  • Namespaces
  • Estructuras de Datos
  • Estructura de datos
  • Índice de estructura de datos
  • Jerarquía de la clase
  • Campos de datos
Métodos públicos
Referencia de la Clase DOMBasicValueException
Diagrama de herencias de DOMBasicValueException
DOMBasicException

Métodos públicos

__construct ($attribName, $value, $expectedValue=null, $variableType= 'attrib')
- Métodos públicos heredados desde DOMBasicException
__construct ($message)

Otros miembros heredados

- Campos de datos heredados desde DOMBasicException
$originalMessage

Documentación del constructor y destructor

__construct | ( | $attribName,
 |  | $value,
 |  | $expectedValue = null,
 |  | $variableType = 'attrib'
 | ) |

Constructs a new DOMBasicValueException on the $name variable.

Parámetros
string | $attribName | The name of the attrib where something was wrong with.
mixed | $value | The value that the option was tried to be set too.
string | $expectedValue | A string explaining the allowed type and value range.
string | $variableType | What type of variable was tried to be set (option, attrib, setting, argument).
La documentación para esta clase fue generada a partir del siguiente fichero:
  • objetosPHP/exceptions/DOMBasicValueException.php


DOMbasic: Referencia de la Clase INI

DOMBasic es un Framework PHP para la creación de elementos DOM que generan contenido HTML dinámico y permite su modificación 'al vuelo' (Websites). Está escrito entéramente en PHP y sigue el paradigma POO.
  • Página principal
  • Namespaces
  • Estructuras de Datos
  • Estructura de datos
  • Índice de estructura de datos
  • Jerarquía de la clase
  • Campos de datos
Métodos públicos estáticos
Referencia de la Clase INI

Métodos públicos estáticos

static | write ($filename, $ini)
static | write_get_string (&$ini, $prefix)
static | set_value ($val)
static | read ($filename)
static | get_value ($val)
static | get_key ($val)
static | manage_keys (&$ini, $key, $val)
static | replace_consts (&$item, $key, $consts)

Descripción detallada

DOWNLOADED OF PHP.NET (AUTHOR: arnapou) Read file : $ini = INI::read('myfile.ini'); Write file : INI::write('myfile.ini', $ini);

Features :

  • support [] syntax for arrays
  • support . in keys like bar.foo.something = value
  • true and false string are automatically converted in booleans
  • integers strings are automatically converted in integers
  • keys are sorted when writing
  • constants are replaced but they should be written in the ini file between braces : {MYCONSTANT}

Documentación de las funciones miembro

static get_key ( $val )
static

manage keys

static get_value ( $val )
static

manage keys

static manage_keys | ( | & | $ini,
 |  |  | $key,
 |  |  | $val
 | ) |  |
static

manage keys

static read ( $filename )
static

READ

static replace_consts | ( | & | $item,
 |  |  | $key,
 |  |  | $consts
 | ) |  |
static

replace utility

static set_value ( $val )
static

manage keys

static write | ( | $filename,
 |  | $ini
 | ) |
static

WRITE

static write_get_string | ( | & | $ini,
 |  |  | $prefix
 | ) |  |
static

write get string

La documentación para esta clase fue generada a partir del siguiente fichero:
  • objetosPHP/util/INI.php


DOMbasic: Índice de estructura de datos

DOMBasic es un Framework PHP para la creación de elementos DOM que generan contenido HTML dinámico y permite su modificación 'al vuelo' (Websites). Está escrito entéramente en PHP y sigue el paradigma POO.
  • Página principal
  • Namespaces
  • Estructuras de Datos
  • Estructura de datos
  • Índice de estructura de datos
  • Jerarquía de la clase
  • Campos de datos
Índice de estructura de datos
C | D | I
C
DOM_element DOMBasicAttribReadOnlyException DOMBasicException
DOM_Interface DOMBasicAutoloadException DOMBasicSingletonException
Configuration DOM_textNode DOMBasicElementNotFoundException DOMBasicValueException
D
DOMBasicAttribNotFoundException DOMBasicElementReadOnlyException
I
DOM_attribs INI
C | D | I


DOMbasic: Jerarquía de la clase

DOMBasic es un Framework PHP para la creación de elementos DOM que generan contenido HTML dinámico y permite su modificación 'al vuelo' (Websites). Está escrito entéramente en PHP y sigue el paradigma POO.
  • Página principal
  • Namespaces
  • Estructuras de Datos
  • Estructura de datos
  • Índice de estructura de datos
  • Jerarquía de la clase
  • Campos de datos
Jerarquía de la clase
Esta lista de herencias esta ordenada aproximadamente por orden alfabético:
[detalle nivel 1234]
▼C ArrayAccess
▼C DOM_attribs
▼C DOM_element
C DOM_textNode
C Configuration
▼C DOM_Interface
C DOM_element
▼C Exception
▼C DOMBasicException
C DOMBasicAttribNotFoundException
C DOMBasicAttribReadOnlyException
C DOMBasicAutoloadException
C DOMBasicElementNotFoundException
C DOMBasicElementReadOnlyException
C DOMBasicSingletonException
C DOMBasicValueException
C INI
▼C IteratorAggregate
C DOM_attribs


DOMbasic: Campos de datos

DOMBasic es un Framework PHP para la creación de elementos DOM que generan contenido HTML dinámico y permite su modificación 'al vuelo' (Websites). Está escrito entéramente en PHP y sigue el paradigma POO.
  • Página principal
  • Namespaces
  • Estructuras de Datos
  • Estructura de datos
  • Índice de estructura de datos
  • Jerarquía de la clase
  • Campos de datos
  • Todo
  • Funciones
  • Variables
  • $
  • _
  • a
  • c
  • e
  • f
  • g
  • i
  • m
  • o
  • p
  • r
  • s
  • t
  • w
Lista de todos los campos de estructuras y uniones documentados con enlaces a la documentación de la estructura/unión para cada campo:

- $ -

  • $_text : DOM_textNode
  • $AVISO_GET : DOM_attribs , DOM_element
  • $originalMessage : DOMBasicException

- _ -

  • __construct() : DOM_attribs , DOMBasicAttribNotFoundException , DOMBasicAttribReadOnlyException , DOMBasicAutoloadException , DOMBasicElementNotFoundException , DOMBasicElementReadOnlyException , DOMBasicException , DOMBasicSingletonException , DOMBasicValueException
  • __get() : DOM_attribs
  • __isset() : DOM_attribs
  • __set() : DOM_attribs
  • __unset() : DOM_attribs , DOM_element

- a -

  • addAttrib() : DOM_attribs
  • addAttribs() : DOM_attribs
  • addChild() : DOM_element , DOM_Interface
  • addChildren() : DOM_element , DOM_Interface
  • arrayFromURL() : DOM_attribs
  • attribsFromURL() : DOM_element
  • attribsToURL() : DOM_element
  • AVISO_SINGLETON : DOM_element

- c -

  • clearAttribs() : DOM_attribs
  • countAttrs() : DOM_attribs

- e -

  • equals() : DOM_attribs , DOM_element
  • equalsType() : DOM_element , DOM_Interface

- f -

  • filtrarStrJSON() : DOM_attribs
  • fromDOM_element() : DOM_element
  • fromJSON() : DOM_element , DOM_Interface
  • fromURL() : DOM_attribs

- g -

  • get_key() : INI
  • get_value() : INI
  • getAttribs() : DOM_attribs
  • getAttribsStr() : DOM_attribs
  • getChildByKey() : DOM_element , DOM_Interface
  • getChildren() : DOM_element , DOM_Interface
  • getChildrenAll() : DOM_element , DOM_Interface
  • getChildrenByTag() : DOM_element , DOM_Interface
  • getChildrenByType() : DOM_element , DOM_Interface
  • getCloseTag() : DOM_element , DOM_Interface
  • getConfiguration() : DOM_element , DOM_Interface
  • getDesc() : DOM_element , DOM_Interface
  • getDTD() : DOM_element
  • getInstance() : DOM_element , DOM_textNode
  • getKey() : DOM_element , DOM_Interface
  • getOpenTag() : DOM_element , DOM_Interface , DOM_textNode
  • getReadOnly() : DOM_attribs
  • getTag() : DOM_element , DOM_Interface
  • getText() : DOM_element
  • getTextAll() : DOM_element
  • getType() : DOM_element , DOM_Interface

- i -

  • importConfINI() : DOM_element , DOM_Interface

- m -

  • manage_keys() : INI

- o -

  • objectToArray() : Configuration
  • objJSON2DOM_element() : DOM_element
  • offsetExists() : DOM_attribs
  • offsetGet() : DOM_attribs
  • offsetSet() : DOM_attribs
  • offsetUnset() : DOM_attribs

- p -

  • PATRON_SINGLETON : DOM_element

- r -

  • READ : DOMBasicAttribReadOnlyException , DOMBasicElementReadOnlyException
  • read() : INI
  • reinicializar() : DOM_attribs
  • removeAttrib() : DOM_attribs
  • removeAttribs() : DOM_attribs
  • removeChild() : DOM_element , DOM_Interface
  • removeChildByKey() : DOM_element , DOM_Interface
  • removeChildrenAll() : DOM_element , DOM_Interface
  • removeChildrenByTag() : DOM_element , DOM_Interface
  • removeChildrenByType() : DOM_element , DOM_Interface
  • replace_consts() : INI

- s -

  • set_value() : INI
  • setAttribs() : DOM_attribs
  • setChildren() : DOM_element , DOM_Interface
  • setConfiguration() : DOM_element , DOM_Interface
  • setKey() : DOM_element , DOM_Interface
  • setReadOnly() : DOM_attribs
  • setText() : DOM_element , DOM_textNode

- t -

  • toHTML() : DOM_element , DOM_Interface
  • toJSON() : DOM_attribs , DOM_element , DOM_Interface
  • toURL() : DOM_attribs
  • tryingWrite() : DOM_attribs , DOM_element

- w -

  • WRITE : DOMBasicAttribReadOnlyException , DOMBasicElementReadOnlyException
  • write() : INI
  • write_get_string() : INI


DOMbasic: Campos de datos - Funciones

DOMBasic es un Framework PHP para la creación de elementos DOM que generan contenido HTML dinámico y permite su modificación 'al vuelo' (Websites). Está escrito entéramente en PHP y sigue el paradigma POO.
  • Página principal
  • Namespaces
  • Estructuras de Datos
  • Estructura de datos
  • Índice de estructura de datos
  • Jerarquía de la clase
  • Campos de datos
  • Todo
  • Funciones
  • Variables
  • _
  • a
  • c
  • e
  • f
  • g
  • i
  • m
  • o
  • r
  • s
  • t
  • w

- _ -

  • __construct() : DOM_attribs , DOMBasicAttribNotFoundException , DOMBasicAttribReadOnlyException , DOMBasicAutoloadException , DOMBasicElementNotFoundException , DOMBasicElementReadOnlyException , DOMBasicException , DOMBasicSingletonException , DOMBasicValueException
  • __get() : DOM_attribs
  • __isset() : DOM_attribs
  • __set() : DOM_attribs
  • __unset() : DOM_attribs , DOM_element

- a -

  • addAttrib() : DOM_attribs
  • addAttribs() : DOM_attribs
  • addChild() : DOM_element , DOM_Interface
  • addChildren() : DOM_element , DOM_Interface
  • arrayFromURL() : DOM_attribs
  • attribsFromURL() : DOM_element
  • attribsToURL() : DOM_element

- c -

  • clearAttribs() : DOM_attribs
  • countAttrs() : DOM_attribs

- e -

  • equals() : DOM_attribs , DOM_element
  • equalsType() : DOM_element , DOM_Interface

- f -

  • filtrarStrJSON() : DOM_attribs
  • fromDOM_element() : DOM_element
  • fromJSON() : DOM_element , DOM_Interface
  • fromURL() : DOM_attribs

- g -

  • get_key() : INI
  • get_value() : INI
  • getAttribs() : DOM_attribs
  • getAttribsStr() : DOM_attribs
  • getChildByKey() : DOM_element , DOM_Interface
  • getChildren() : DOM_element , DOM_Interface
  • getChildrenAll() : DOM_element , DOM_Interface
  • getChildrenByTag() : DOM_element , DOM_Interface
  • getChildrenByType() : DOM_element , DOM_Interface
  • getCloseTag() : DOM_element , DOM_Interface
  • getConfiguration() : DOM_element , DOM_Interface
  • getDesc() : DOM_element , DOM_Interface
  • getDTD() : DOM_element
  • getInstance() : DOM_element , DOM_textNode
  • getKey() : DOM_element , DOM_Interface
  • getOpenTag() : DOM_element , DOM_Interface , DOM_textNode
  • getReadOnly() : DOM_attribs
  • getTag() : DOM_element , DOM_Interface
  • getText() : DOM_element
  • getTextAll() : DOM_element
  • getType() : DOM_element , DOM_Interface

- i -

  • importConfINI() : DOM_element , DOM_Interface

- m -

  • manage_keys() : INI

- o -

  • objectToArray() : Configuration
  • objJSON2DOM_element() : DOM_element
  • offsetExists() : DOM_attribs
  • offsetGet() : DOM_attribs
  • offsetSet() : DOM_attribs
  • offsetUnset() : DOM_attribs

- r -

  • read() : INI
  • reinicializar() : DOM_attribs
  • removeAttrib() : DOM_attribs
  • removeAttribs() : DOM_attribs
  • removeChild() : DOM_element , DOM_Interface
  • removeChildByKey() : DOM_element , DOM_Interface
  • removeChildrenAll() : DOM_element , DOM_Interface
  • removeChildrenByTag() : DOM_element , DOM_Interface
  • removeChildrenByType() : DOM_element , DOM_Interface
  • replace_consts() : INI

- s -

  • set_value() : INI
  • setAttribs() : DOM_attribs
  • setChildren() : DOM_element , DOM_Interface
  • setConfiguration() : DOM_element , DOM_Interface
  • setKey() : DOM_element , DOM_Interface
  • setReadOnly() : DOM_attribs
  • setText() : DOM_element , DOM_textNode

- t -

  • toHTML() : DOM_element , DOM_Interface
  • toJSON() : DOM_attribs , DOM_element , DOM_Interface
  • toURL() : DOM_attribs
  • tryingWrite() : DOM_attribs , DOM_element

- w -

  • write() : INI
  • write_get_string() : INI


DOMbasic: Campos de datos - Variables

DOMBasic es un Framework PHP para la creación de elementos DOM que generan contenido HTML dinámico y permite su modificación 'al vuelo' (Websites). Está escrito entéramente en PHP y sigue el paradigma POO.
  • Página principal
  • Namespaces
  • Estructuras de Datos
  • Estructura de datos
  • Índice de estructura de datos
  • Jerarquía de la clase
  • Campos de datos
  • Todo
  • Funciones
  • Variables
  • $_text : DOM_textNode
  • $AVISO_GET : DOM_attribs , DOM_element
  • $originalMessage : DOMBasicException
  • AVISO_SINGLETON : DOM_element
  • PATRON_SINGLETON : DOM_element
  • READ : DOMBasicAttribReadOnlyException , DOMBasicElementReadOnlyException
  • WRITE : DOMBasicAttribReadOnlyException , DOMBasicElementReadOnlyException


DOMbasic: Referencia del directorio objetosPHP/exceptions

DOMBasic es un Framework PHP para la creación de elementos DOM que generan contenido HTML dinámico y permite su modificación 'al vuelo' (Websites). Está escrito entéramente en PHP y sigue el paradigma POO.
  • Página principal
  • Namespaces
  • Estructuras de Datos
  • objetosPHP
  • exceptions
Referencia del directorio exceptions

Archivos

archivo | DOMBasicAttribNotFoundException.php
archivo | DOMBasicAttribReadOnlyException.php
archivo | DOMBasicAutoloadException.php
archivo | DOMBasicElementNotFoundException.php
archivo | DOMBasicElementReadOnlyException.php
archivo | DOMBasicException.php
archivo | DOMBasicSingletonException.php
archivo | DOMBasicValueException.php


DOMbasic: Referencia del directorio objetosPHP

DOMBasic es un Framework PHP para la creación de elementos DOM que generan contenido HTML dinámico y permite su modificación 'al vuelo' (Websites). Está escrito entéramente en PHP y sigue el paradigma POO.
  • Página principal
  • Namespaces
  • Estructuras de Datos
  • objetosPHP
Referencia del directorio objetosPHP

Directorios

directorio | DOCS
directorio | examples
directorio | exceptions
directorio | util

Archivos

archivo | DOM_attribs.php
archivo | DOM_element.php
archivo | DOM_Interface.php
archivo | DOM_textNode.php


DOMbasic: Referencia del directorio objetosPHP/DOCS

DOMBasic es un Framework PHP para la creación de elementos DOM que generan contenido HTML dinámico y permite su modificación 'al vuelo' (Websites). Está escrito entéramente en PHP y sigue el paradigma POO.
  • Página principal
  • Namespaces
  • Estructuras de Datos
  • objetosPHP
  • DOCS
Referencia del directorio DOCS

Directorios

directorio html


DOMbasic: Referencia del directorio objetosPHP/DOCS/html/search

DOMBasic es un Framework PHP para la creación de elementos DOM que generan contenido HTML dinámico y permite su modificación 'al vuelo' (Websites). Está escrito entéramente en PHP y sigue el paradigma POO.
  • Página principal
  • Namespaces
  • Estructuras de Datos
  • objetosPHP
  • DOCS
  • html
  • search
Referencia del directorio search

Archivos

archivo | all_0.js
archivo | all_1.js
archivo | all_2.js
archivo | all_3.js
archivo | all_4.js
archivo | all_5.js
archivo | all_6.js
archivo | all_7.js
archivo | all_8.js
archivo | all_9.js
archivo | all_a.js
archivo | all_b.js
archivo | all_c.js
archivo | all_d.js
archivo | all_e.js
archivo | all_f.js
archivo | classes_0.js
archivo | classes_1.js
archivo | classes_2.js
archivo | functions_0.js
archivo | functions_1.js
archivo | functions_2.js
archivo | functions_3.js
archivo | functions_4.js
archivo | functions_5.js
archivo | functions_6.js
archivo | functions_7.js
archivo | functions_8.js
archivo | functions_9.js
archivo | functions_a.js
archivo | functions_b.js
archivo | functions_c.js
archivo | namespaces_0.js
archivo | search.js
archivo | searchdata.js
archivo | variables_0.js
archivo | variables_1.js
archivo | variables_2.js
archivo | variables_3.js
archivo | variables_4.js


DOMbasic: Referencia del directorio objetosPHP/examples

DOMBasic es un Framework PHP para la creación de elementos DOM que generan contenido HTML dinámico y permite su modificación 'al vuelo' (Websites). Está escrito entéramente en PHP y sigue el paradigma POO.
  • Página principal
  • Namespaces
  • Estructuras de Datos
  • objetosPHP
  • examples
Referencia del directorio examples

Archivos

archivo | comparation.php
archivo | example1.php


DOMbasic: Referencia del directorio objetosPHP/util

DOMBasic es un Framework PHP para la creación de elementos DOM que generan contenido HTML dinámico y permite su modificación 'al vuelo' (Websites). Está escrito entéramente en PHP y sigue el paradigma POO.
  • Página principal
  • Namespaces
  • Estructuras de Datos
  • objetosPHP
  • util
Referencia del directorio util

Archivos

archivo | INI.php
archivo | JsonIniXml.php
archivo | Utiles.php


DOMbasic: Referencia del directorio objetosPHP/DOCS/html

DOMBasic es un Framework PHP para la creación de elementos DOM que generan contenido HTML dinámico y permite su modificación 'al vuelo' (Websites). Está escrito entéramente en PHP y sigue el paradigma POO.
  • Página principal
  • Namespaces
  • Estructuras de Datos
  • objetosPHP
  • DOCS
  • html
Referencia del directorio html

Directorios

directorio search

Archivos

archivo | annotated_dup.js
archivo | class_configuration.js
archivo | class_d_o_m__attribs.js
archivo | class_d_o_m__element.js
archivo | class_d_o_m__text_node.js
archivo | class_d_o_m_basic_attrib_not_found_exception.js
archivo | class_d_o_m_basic_attrib_read_only_exception.js
archivo | class_d_o_m_basic_autoload_exception.js
archivo | class_d_o_m_basic_element_not_found_exception.js
archivo | class_d_o_m_basic_element_read_only_exception.js
archivo | class_d_o_m_basic_exception.js
archivo | class_d_o_m_basic_singleton_exception.js
archivo | class_d_o_m_basic_value_exception.js
archivo | dynsections.js
archivo | hierarchy.js
archivo | interface_d_o_m___interface.js
archivo | jquery.js
archivo | namespaces.js
archivo | navtree.js
archivo | navtreedata.js
archivo | navtreeindex0.js
archivo | resize.js


DOMbasic: Página principal

DOMBasic es un Framework PHP para la creación de elementos DOM que generan contenido HTML dinámico y permite su modificación 'al vuelo' (Websites). Está escrito entéramente en PHP y sigue el paradigma POO.
  • Página principal
  • Namespaces
  • Estructuras de Datos
DOMbasic Documentación