LATEX maths and graphics

Tim Love

August 5, 1999

This handout assumes that you have already read the Advanced LaTex document handout, so if you're unsure about `environments', read no further. LATEX produces maths text well, but graphic support is less good. Fortunately there's a graphics editor called xfig whose output can be used in a LATEX file.

Note that there's an alternative way of producing maths in LATEX - [image] -LATEX

  • Maths

    • Environments
    • Special Characters
      • Greek
      • Miscellaneous
      • Arrows
      • Calligraphic
      • Character Modifiers
      • Common functions
    • Subscripts and superscripts
    • Overlining, underlining and bold characters
    • Roots
    • Fractions
    • Delimiters
    • Numbering and labelling
    • Matrices
    • Macros
    • Packages
    • Fine tuning
    • Maths and Postscript fonts
    • Matlab and LaTeX
    • Examples
  • Graphics
    • Postscript
      • psfrag: adding maths to postscript files
      • Postscript from PCs/Macs
    • Scaling, rotation, clipping, wrap-around and shadows
    • GIF and jpeg files
    • Bitmaps
    • Graphs


Environments

There are 2 environments to display one-line equations.

equation:-

Equations in this environment are numbered.

\begin{equation}
 x + iy
\end{equation}

x + iy

(1)

displaymath:-

These won't be numbered. \[, \] can be used as abbreviations for \begin{displaymath} and \end{displaymath}.

\begin{displaymath}
 x + iy
\end{displaymath}

x + iy

Never leave a blank line before these equations; it starts a new paragraph and looks ugly. '\displaystyle' is the font type used to print maths in these display environments. Other relevant environments are:-

math:-

For use in text. \( and \) can be used to delimit the environment, as can the TEX constructions $ and $ . For example, $x=y^2$ gives x=y2.

eqnarray:-

This is like a 3 column tabular environment. Each line by default is numbered. You can use the eqnarray* variant to suppress numbering altogether.

\begin{eqnarray}
a1 & = & b1 + c1\nonumber\\
a2 & = & b2 - c2
\end{eqnarray}

a1

=

b1 + c1

a2

=

b2 - c2

(2)

Maths in these 2 sorts of environments have different default sizes for some characters and other behavioural differences so that a line of maths won't impinge on text lines below or above. If you want to put some non-maths text in amongst maths then enclose it in an \mbox{...}.


Special Characters

  • Greek

  • Miscellaneous
  • Arrows
  • Calligraphic
  • Character Modifiers
  • Common functions


Greek

\alpha | \beta | \gamma | \delta |  | \epsilon
\zeta | \eta | \theta | \iota |  | \kappa
\lambda | \mu | \nu | \xi | o | o
\pi | \rho | \sigma | \tau |  | \upsilon
\phi | \chi | \psi | \omega |  | \Gamma
\Delta | \Theta | \Lambda | \Xi |  | \Pi
\Sigma | \Upsilon | \Phi | \Psi |  | \Omega


Miscellaneous

\ldots | \cdots | \vdots
\ddots | \pm | \mp
\times | \div | \ast
\star | \circ | \bullet
\cdot | \cap | \bigcap
\cup | \bigcup | \uplus
\biguplus | \sqcap | \sqcup
\bigsqcup | \vee | \bigvee
\wedge | \bigwedge | \setminus
\wr | \diamond | \bigtriangleup
\bigtriangledown | \triangleleft | \triangleright
\oplus | \bigoplus | \ominus
\otimes | \bigotimes | \oslash
\odot | \bigodot | \bigcirc
\amalg | \leq | \prec
\preceq | \ll | \subset
\subseteq | \sqsubseteq | \in
\vdash | \geq | \succ
\succeq | \gg | \supset
\supseteq | \sqsupseteq | \ni
\dashv | \equiv | \sim
\simeq | \asymp | \approx
\cong | \neq | \doteq
\propto | \models | \perp
\mid | \parallel | \bowtie
\smile | \frown | \aleph
\hbar | \imath | \jmath
\ell | \wp | \Re
\Im | \prime | \empty
\nabla | \surd | \top
\bot | \| | \angle
\forall | \exists | \neg
\flat | \natural | \sharp
\backslash | \partial | \infty
\triangle | \sum | \prod
\coprod | \int | \oint


Arrows

\leftarrow | \Leftarrow | \rightarrow
\Rightarrow | \leftrightarrow | \Leftrightarrow
\mapsto | \hookleftarrow | \leftharpoonup
\leftharpoondown | \rightleftharpoons | \longleftarrow
\Longleftarrow | \longrightarrow | \Longrightarrow
\longleftrightarrow | \Longleftrightarrow | \longmapsto
\hookrightarrow | \rightharpoonup | \rightharpoondown
\uparrow | \Uparrow |
\downarrow | \Downarrow | \updownarrow
\nearrow | \searrow | \swarrow
\nwarrow |  |


Calligraphic

These characters are available if you use the \cal control sequence.

${\cal A B C D E F G H I J K L M N O P Q R S T U V W X Y Z}$

gives


Character Modifiers

\hat{e} | \widehat{easy}
\tilde{e} | \widetilde{easy}
\check{e} | \breve{e}
\acute{e} | \grave{e}
\bar{e} | \vec{e}
\dot{e} | \ddot{e}
\not e |

Note that the wide versions of hat and tilde cannot produce very wide alternatives. The `\not' operator hasn't properly cut the following letter. The Fine Tuning section on page [*] describes how to adjust this.

If you want to place one character above another, you can use \stackrel, which prints its first argument in small type immediately above the second

$ a \stackrel{def}{=} b + c $

gives

See the Macros section for how to stack characters using atop.


Common functions

In a maths environment, LATEX assumes that variables will have single-character names. Function names require special treatment. The advantage of using the following control sequences for common functions is that the text will not be put in math italic and subscripts/superscripts will be made into limits where appropriate.

\arccos | \arcsin | \arctan | \arg | \cos | \cosh | \cot
\coth | \csc | \deg | \det | \dim | \exp | \gcd
\hom | \inf | \ker | \lg | \lim | \liminf | \ln
\log | \max | \min | \Pr | sec | \sin | \sinh
\sup | \tan | \tanh |  |  |  |


Subscripts and superscripts

These are introduced by the `^' and `_' characters. Depending on the base character and the current style, the sub- or superscripts may go to the right of or directly above/below the main character. With letters it goes to the right.

$F_2^3$

produces `F23'. Note that the sub- and superscripts aren't in line. To make them so, you can add an invisible character after the `F'. $F{}_2^3$ produces F23.

With [image] the default behaviour is different in display and text styles.

$\sum_{i=0}^2 $

produces [image] (text style) but

\[\sum_{i=0}^2 \]

produces (in display style)

This default behaviour can be overridden, if you really need to. For example in text mode,

$\sum\limits_{i=0}^2$

produces


Overlining, underlining and bold characters

$\underline{one} \overline{two}$

produces [image]. This is not a useful facility if it's used more than once on a line. The lines are produced so that they don't quite overlap the text; lines over or under different words won't in general be at the same height.

To be able to reproduce bold maths, it's best to use the bm package. $E = \bm{mc^2}$ produces E = mc2.

Alternatively, you can use \mathbf{} to create bold characters - $\mathbf{F}_2^3$ produces F23. or you can use the following idea

\usepackage{amsbsy} % This loads amstext too
\begin{document}
$\omega + \boldsymbol{\omega}$

% Use the following if whole expressions need to be in bold
{\boldmath $\omega $}
\end{document}


Roots

$\sqrt{4} + \sqrt[3]{x + y}$

gives [image].


Fractions

Three constructions for putting expressions above others are

frac:-

$\frac{1}{(x + 3)}$ produces [image].

choose:-

${n + 1 \choose 3}$ produces [image].

atop:-

${x \atop y}$ produces [image].

These constructions can be used with ones described earlier. E.g.,

\[ \sum_{-1\le i \le 1 \atop 0 < j < \infty} f(i,j)\]

gives


Delimiters

these | are made by these | and these | are made by these
( | ( | ) | )
[ | [ | ] | ]
 | \{ |  | \}
 | \lfloor |  | \rfloor
 | \lceil |  | \rceil
 | \langle |  | \rangle
/ | / |  | \backslash
| | | |  | \|
 | \uparrow |  | \Uparrow
 | \downarrow |  | \Downarrow
 | \updownarrow |  | \Updownarrow

This table shows the standard sizes. To get bigger sizes, use these prefices

(for left delimiters) | (for right delimiters) | magnification
\bigl | \bigr | a bit bigger, but won't overlap lines
\Bigl | \Bigr | 150% times big
\biggl | \biggr | 200% times big
\Biggl | \Biggr | 250% times big

For example,

$\Biggl\{2\Bigl(x(3+y)\Bigr)\Biggr\}$

gives [image]. If you're not using the default text size these commands might not work correctly. In that case try the exscale package.

It's preferable to let LATEX choose the delimiter size for you by using \left and \right. These will produce delimiters just big enough for the formulae inbetween.

$\left( frac{(x+iy)}{\{\int x\}} \right)$

gives

The left and right delimiters needn't be the same type. It's sometimes useful to make one of them invisible

\[ z = \left\{
              \begin{array}{ll}
                   1 & (x>0)\\
                   0 & (x<0)
              \end{array}
       \right.
\]

produces

Over- and underbracing works too.

$\overbrace{\alpha \ldots \omega}^{\mbox{greek}}
 \underbrace{a \ldots z}_{\mbox{english}}$

produces [image]. The use of \mbox stops the text appearing in math italic.


Numbering and labelling

Numbering happening automatically when you display equations. If you don't want an equation numbered, use \nonumber beside the equation. Equation numbers appear to the right of the maths by default. To make them appear on the left use the leqno class option (i.e., use \documentclass[leqno,....]{....}).

Use \label{} to label an equation (or figure, section etc) in order to reference from elsewhere.

\begin{equation}
W_{\bf S}(t,\omega) = \int\limits_{-\infty}^{\infty} {
  {\cal R}_{\bf S}(t,\tau) e^{-j\omega\tau} \,d \tau }
\label{LABELLING}
\end{equation}

(3)

Now the following text

 refers back to equation \ref{LABELLING}

refers back to equation 3 by number, and

 refers back to the equation on page \pageref{LABELLING}

refers back to the equation on page [*] .

A file will have to be LATEX'ed twice before the references, both forwards and backwards, will be correctly produced.


Matrices

The array environment is like LATEX's tabular environment except that each element is in math mode. The default font style used is \textstyle but you can override this by changing the \displaystyle.

\begin{math}
\begin{array}{clrr} %
      a+b+c & uv & x-y & 27 \\
       x+y  & w  & +z  & 363
\end{array}
\end{math}

produces

The rows are arranged so that their centres are aligned. You can align their tops or bottoms instead by using a further argument when you create the array.

\begin{array}{clrr}[t]

would produce top-aligned lines, and `[b]' would produce bottom-aligned ones. The Delimiters section of this document shows how to bracket matrices.

TEX has a few maths facilities not mentioned in the LATEX book. The following TEX construction might be useful.

\begin{math}
\bordermatrix{&a_1&a_2&...&a_n\cr
          b_1 & 1.2  & 3.3  & 5.1  & 2.8  \cr
          c_1 & 4.7  & 7.8  & 2.4  & 1.9  \cr
          ... & ...  & ...  & ...  & ...  \cr
          z_1 & 8.0  & 9.9  & 0.9  & 9.99  \cr}
\end{math}


Macros

These aid readability, save on repetitive typing and offer ways of producing stylistic variations on standard LATEX formats.

\def\bydefn{\stackrel{def}{=}}
\def\convf{\hbox{\space \raise-2mm\hbox{$\textstyle
    \bigotimes \atop \scriptstyle \omega$} \space}}

produce [image] and [image] when $\bydefn$ and $\convf$ are typed.


Packages

The following packages may be of help

  • easybmat - easy block matrices

  • easyeqn - easy equations.

  • easymat - easy matrices

  • easytable - easy tables

  • easyvector - easy vectors

  • delarray - nested arrays

  • theorem - gives more choice in theorem layout

  • subeqnarray - Renumbering of sub-arrays in math-mode

  • subeqn - Different numbering sub-arrays


Fine tuning

It's generally a good idea to keep punctuation outside math mode; LATEX's normal handling of spacing around punctuation is suspended during maths. Sometimes you might want to adjust the spacing in a formula (e.g., you might want to add space before dx). Use these symbols :-

a\, b | ( [image] ) thin space
a\ b | ( [image] ) medium space
a\; b | ( [image] ) thick space
a\! b | ( [image] ) negative thin space

Long math expressions aren't broken automatically unless you use the breen package, which is still a little experimental. In an eqnarray environment you may want to break a long line manually. You can do this by puttingt

y & = & a + b \nonumber \\
  &   & + k

to give

y | = | a + b |
 |  | + k | (4)

but the spacing around the `+' on the 2nd line is wrong because LATEX thinks it's a unary operator. You can fool LATEX into treating it as a binary operator by inserting a hidden character.

y & = & a + b \nonumber \\
  &   & \mbox{} + k

gives

y | = | a + b |
 |  |  | (5)

You can use the \lefteqn construction to format long expressions so that continuation lines are differently indented.

\begin{eqnarray}
\lefteqn{x+ iy=}\\
 & & a + b + c + d + e + f + g + h + i + j + k +\nonumber\\
 & & l + m \nonumber
\end{eqnarray}

x+ iy=
 | a + b + c + d + e + f + g + h + i + j + k +
 | l + m

If you want more vertical spacing around a line you can create an invisible vertical "struct" in LaTeX. \rule[-.3cm]{0cm}{1cm} creates a box of width 0, height 1cm which starts .3cm below the usual line base. By adjusting these values you should be able to create as much extra space below/above the maths as you like. and is created by

$A \over B$  \rule[-.3cm]{0cm}{1cm}{and}


Maths and Postscript fonts

It's easy to use a postscript font (like helvetica) for the text of a LATEX document. What's harder is using the same font for maths. An easy, reasonable option is to use the mathptm package to put the maths into the postscript Times font.


Matlab and LaTeX

Matlab has some support for LaTeX production. For example

  latex('(sin(x)+2*x+3*x^2)/(5*x+6*x^2)','math.tex')

puts the LaTeX representation of the expression into a file called math.tex. Type ``help latex" inside matlab for details.


Examples

  •
    • \begin{equation}
    \hat{\theta}_{w_i} = \hat{\theta}(s(t,{\cal U}_{w_i})).
    \end{equation}

    gives

    (7)

  •
    • \begin{eqnarray}
    {\cal M}^2(\hat{\theta},\theta) &=& E[(\hat{\theta} - \theta)^2]
    \nonumber \\
    {\cal M}^2(\hat{\theta},\theta) &=& {\rm var}^2(\hat{\theta}) +
    {\cal B}^2(\hat{\theta}).
    \end{eqnarray}

    gives

    = |
= | (8)

  •
    • \begin{equation}
    \hat{W}_{s}(t,\omega;\phi) \bydefn
    \int\limits_{-\infty}^{\infty}
    {\hat{\cal R}_s(t,\tau;\psi) e^{-j\omega \tau}
    \, d \tau }
    \end{equation}

    gives

    (9)

  •
    • \begin{eqnarray}
    {\cal B}(t,\omega) & \approx &
    {1 \over 4\pi}
    {\cal D}_t^2 W_{\bf S}(t, \omega)
    {{{\scriptstyle \infty} \atop
    {\displaystyle \int \! \int \!
    }}\atop {\scriptstyle -\infty}}
    t_1^2
    \phi(t_1,\omega_1) \, dt_1 d\omega_1
    \nonumber \\
    && +
    {1 \over 4\pi}
    {\cal D}_\omega^2 W_{\bf S}(t, \omega)
    {{{\scriptstyle \infty} \atop
    {\displaystyle \int \! \int \!
    }}\atop {\scriptstyle -\infty}}
    \omega_1^2
    \phi(t_1,\omega_1) \, dt_1 \, d\omega_1.
    \label{F4}
    \end{eqnarray}

    gives

    (10)

  •
    • \newsavebox{\DERIVBOXZLM}
    \savebox{\DERIVBOXZLM}[2.5em]{$\Longrightarrow\hspace{-1.5em}
    \raisebox{.2ex}{*}
    \hspace{-.7em}\raisebox{-.8ex}{\scriptsize lm}\hspace{.7em}$}
    \newcommand{\Deriveszlm}{\usebox{\DERIVBOXZLM}}

    \Deriveszlm

    gives


Graphics

LATEX has a picture environment in which pictures can be drawn, but you'll find graph paper handy. xfig can create code for the picture environment but the resulting graphics still suffer several limitations: only certain slopes and circles can be reproduced. The best method presently available on Unix is to use xfig to produce postscript files, which have no such limitations, but require a postscript printer or equivalent.

Whatever graphics you want to add, you should use the figure environment so that LATEX can cope sensibly with situations where, for example, you attempt to insert near the bottom of a page a graphic that's half a page high. The figure environment will float the graphic to the top or bottom of the page, or on the next page, with preferences that you can provide.

h | here
t | top of page
b | bottom of page
p | on a page with no text

Putting ! as the first argument in the square brackets will encourage LATEX to do what you say, even if the result's sub-optimal.

\begin{figure}[htbp]
   \vspace{0.5in}
   \caption{0.5 inch of space}
\end{figure}

Figure 1: 0.5 inch of space

It's possible to have more than one graphic in a figure. See the example later on.

  • Postscript

    • psfrag: adding maths to postscript files
    • Postscript from PCs/Macs
  • Scaling, rotation, clipping, wrap-around and shadows
  • GIF and jpeg files
  • Bitmaps
  • Graphs


Postscript

It's easy to incorporate Postscript files as long as they have a proper bounding box comment; i.e. LATEX requires full Encapsulated Postscript as produced by (for example) xv and xfig on the HPs. If the file hasn't got a BoundingBox line near the top, you can use ps2epsi to generate one. Wherever the postscript file comes from, simply use

\documentclass[dvips]{article}
\usepackage{graphicx}

then include the postscript file using the following commands

\begin{figure}[htbp]
\includegraphics{yourfile.ps}
\end{figure}

LATEX can cope with compressed postscript files too. The following works

\begin{figure}[htbp]
\includegraphics{yourfile.ps.gz}
\end{figure}

Just about all of the following facilities use postscript. You'll need to run latex to generate `foo.dvi'. This file can be viewed by the latest xdvi program, which can cope with embedded postscript. Run dvips -o foo.ps foo.dvi to convert the resulting DVI/postscript file to pure postscript. This will produce a file that can be previewed with ghostview or gs. On the teaching system this file can be printed out using plotview or

  lp -dljmr1 -opostscript foo.ps

  • Postscript from PCs/Macs


psfrag: adding maths to postscript files

Many packages that produce postscript output don't provide good maths facilities. It's often easier to add the maths in later using the psfrag package. This lets you replace text in a postscript file (produced with xfig, matlab, etc) by a fragment of LATEX. See the online documentation for details.


Postscript from PCs/Macs

Modern applications should generate a conforming EPS file. Under windows when you're printing to file, look at the PostScript properties, and choose at the top of the window either 'Archive Format' or 'Encapsulated PS' or 'Optimize for Portability'. If you have problems on a Macintosh, check that you're using the LaserWriter 8 driver. Platform-specific considerations do crop up. The EPS generated on the Macintosh will use ASCII 13 line terminators, while Unix will use ASCII 10 (and DOS will use both). If this causes trouble, use emacs to convert, or try (in Unix)

     tr "\015" "\012" <original.ps >new.ps


Scaling, rotation, clipping, wrap-around and shadows

To scale, use some optional arguments

   \includegraphics[width=5cm,height=10cm]{yourfile.ps}

would rescale the postscript so that it was 5cm wide and 10cm high. To make the picture 5cm wide and scale the height in proportion use

   \includegraphics[width=5cm]{yourfile.ps}

To rotate anticlockwise by the specified number of degrees, use

   \includegraphics[angle=150]{yourfile.ps}

The following examples demonstrate how to combine these features and how to use the subfigure package to have more than one graphic in a figure.

Figure 2: Tigers

\begin{figure}[hbtp]
  \includegraphics[height=40mm]{/export/ghostfonts/tiger.eps}
  \includegraphics[angle=120, height=20mm]{/export/ghostfonts/tiger.eps}
\caption{Tigers}
\end{figure}

% remember to do \usepackage{subfigure} at the top of the document!
\begin{figure}[hbtp]
\begin{center}
% an mbox for alignment
\mbox{\subfigure[Small]
{\includegraphics[height=30mm]{/export/ghostfonts/crest.eps}}\quad
\subfigure[Medium]
{\includegraphics[height=40mm]{/opt/latex/ps/color_CU_arms.ps}}\quad
\subfigure[Large]
{\includegraphics[height=50mm]{/export/ghostfonts/crest.eps}}
}% end of mbox
\caption{3 crests}
\end{center}
\end{figure}

Figure 3: 3 crests

[Small] [image] [Medium] [image] [Large]

To clip the postscript image use the viewpoint argument. The following fragment would display only part of the image. The viewport coordinates are in the same units as the bounding box.

\begin{figure}[htbp]
\includegraphics[viewport=200 400 400 600,width=5cm,clip]%
{/opt/latex/ps/color_CU_arms.ps}
\end{figure}

% Use the floatflt package
\begin{floatingfigure}[l]{4cm}
\includegraphics[width=2cm]{/export/ghostfonts/crest.eps}
\caption{Using floatingfigure}
\end{floatingfigure}

Figure 4: Using floatingfigure

4cm

The floatflt package lets you insert a graphic and have the text wrap around it. You can provide 2 arguments to the floatingfigure command: the first (l or r) selects whether you want the graphic to be on the left or right of the page. The 2nd argument gives the width of the graphic. Not all text will flow perfectly around (for example, verbatim text fails) so check the final output carefully.

Using the fancybox package gives you access to \shadowbox, \ovalbox, \Ovalbox and \doublebox commands, which can be used with text or with graphics. For example, \shadowbox{shadow package} produces shadow package and

\ovalbox{\includegraphics[height=10mm]{/opt/latex/ps/color_CU_arms.ps}}

produces [image]. Unfortunately, the fancybox package as supplied suppresses the table of contents. The locally produced contentsfancybox solves this, but may introduce graphics problems.


GIF and jpeg files

CUED users can include a file called keyboard.gif, for example, by doing gif2ps -b keyboard.gif (as long as you don't change the GIF file you need only do this once) and then including the GIF file as you would a postscript one.

For JPEG files run "jpeg2ps -h file.jpg > file.eps" then include the postscript file in the usual way. The resulting eps file will be little bigger than the original file. Alternatively, if you put the 'Bounding Box' line from the eps file and put it in file.jpg.bb you can include JPEG files in the same way that you do postscript files.


Bitmaps

If you want to include a small X11 bitmap into your document, you can use the Bitmap macro.

\usepackage{bitmap}
\begin{document}
\Bitmap{/usr/local/include/X11/bitmaps/cued_icons/kettle.px}{1pt}
Now in a frame
\vspace{.5cm}
\fbox{\vbox{\Bitmap{/usr/local/include/X11/bitmaps/cued_icons/xpc.px}{1pt}}}
\end{document}

/usr/local/include/X11/bitmaps/cued_icons/kettle.px1pt Now in a frame


Graphs

Probably the easiest way to put complicated graphs into LATEX is to use gnuplot or Matlab, and produce encapsulated postscript output.

The ebar package (a local version of the bar package) is ok for simpler graphs. See The LATEX Companion for more details.

\begin{center}
\textbf{CUED Gopher Usage, 1994}

\begin{figure}[htbp]
\begin{barenv}
% set the 'z' axis depth
\setdepth{10}
%Scale the height
\setstretch{.01}
% Put the numbers above the bars. Other options include 'empty',
\setnumberpos{up}
% Set type of x labels (numbers by default) but could also be 'days'
\setxvaluetyp{month}
% Set the x origin, end, and step size
\setxaxis{1}{3}{1}\setxname{Activity}
% Set the y origin, end, and step size
\setyaxis{0}{10000}{1000}\setyname{Accesses}
\ebar{6768}{1}
\ebar{9917}{2}
\ebar{8306}{3}
\end{barenv}
\end{figure}
\end{center}

CUED Gopher Usage, 1994


Maths

There's more to maths typesetting than meets the eye. Many conventions used in the typesetting of plain text are inappropriate to maths. LATEX goes a long way to help you along with the style. For example, in a LATEX maths environment, letters come out in italics, `-' as `-' (minus) instead of the usual `-' (dash), `*' becomes *, ' becomes ' and spacing is changed (less around `/', more around `+').

Many of the usual LATEX constructions can still be used in maths environments but their effect may be slightly different; eg \textbf{ } only affects letters and numbers. `{' and `}' are still special characters; they're used to group characters.

As usual in LATEX you can override the defaults, but think before doing it: maths support in LATEX has been carefully thought out and is quite logical though the LATEX source text may not be very readable. It's a good idea to write out the formulae on paper before you start LATEXing, and try not to overdo the use of the `\frac' construction; use `/' instead.

  • Environments

  • Special Characters
    • Greek
    • Miscellaneous
    • Arrows
    • Calligraphic
    • Character Modifiers
    • Common functions
  • Subscripts and superscripts
  • Overlining, underlining and bold characters
  • Roots
  • Fractions
  • Delimiters
  • Numbering and labelling
  • Matrices
  • Macros
  • Packages
  • Fine tuning
  • Maths and Postscript fonts
  • Matlab and LaTeX
  • Examples